I got a brand new APM1 recently. I soldered it quickly. But when I tried to upload the firmware the mission planner could not detect the APM version. I have not debugged it completely bit seems that it does not have the boot loader. It also appears that the atmega328  does not have the PPM firmware installed.
When I power the board without connecting the Oilpan, I can see that.
  • The power led is on
  • The mux and the PPM led is off.
  • Arduino is unable to communicate with the board.
  • The mission planner is unable to detect the APM version.
I have more that one APM1 and on the other APM1 I see that when I power the rails. The mux/PPM activity led's are on and Arduino is able to load arduino sketch on it. So my wild guess is that there is no boot loader on the mega2560. I will try to connect my Atmel Dragon and see if I can communicate with the chip later today when I get back home.
Has anyone else seen a case where the mega2560 is missing the boot loader? Or something else is wrong with my board.?

Views: 3065

Reply to This

Replies to This Discussion

Hello Raphael Diaz,

  Can you please point me where you got the hex file for the atmega2560 bootloader. I will use it to burn the bootloader in my APM1.


Cool Dude,

Check the link that I provided for burning the bootloader with the Arduino IDE. I believe that it points you to the location in the IDE file structure that has the various Atmel bootloaders.



After much research, I managed to load the bootloader unto the APM2560 using my $4.95 usbasp device connected to the SPI connector on the APM2560. I used avrdude 5.11 in the windows terminal to set the fuses and load stk500boot_v2_mega 2560.hex to the APM2560. There were SCK and verification errors but when I connected it to Mission Planner it uploaded APM 2.7.3 without problems. Conclusion, 3DR must have shipped the boards without bootloaders. I sent an email to their help desk on Sept 28 and  still have not heard from them. I learnt more than I wanted to about flashing and would prefer to spend my time tuning PIDs!!


I think there is more to the missing bootloader than you might think.  I am in the same situation here.  But when I finish putting bootloader and upload APM firmware.  I notice that the LEDs in the bottom board are different.  Usually with APM1, there are 3 LEDs that are always on, red, blue, and yellow.  Now PPM and MUX LEDs are always off (Blue and Yellow LED in the bottom shelf).  Only the red LED stay lid.  So I connect Mission Planner to this APM1 to find that there are no radio input even though I connect the R/C receiver to APM1.  My guess is that they might miss PPM/MUX firmware on these boards too. 

Best wishes,


Hello Peter,

  I had the same issue. No boot loader in Mega2560 and no PPM firmware in the PPM chip. I had to flash both and now it works fine. I have AVR Dragon, which I used to flash the bootloader and the PPM firmware.


You have to use both ISP ports. One for the 2560 bootloader and one for the 328 bootloader. Then you have to load the 328 with PPM/Mux firmware.

Just a thought.



Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service