I've been testing my purple board through the USB and it works good enough to replace an ArduPilot Mega 1 on an EasyStar.  Everything is connected and the power jumper is in so the ESC is supplying system power.

But, the APM2 will not start up on either ESC or UBEC power.  Even wired in, it still boots on the USB power, as it has always done.  The APM1 never had any problems with power on this plane and another APM1 always works on a T-28.

Has anyone seen this problem with ESC/UBEC power? 

Views: 2379

Reply to This

Replies to This Discussion

I have recently developed a similar problem as well. At first the problem seemed to be that when I had the minimosd board connected the APM2 would hang on boot. Sometimes I would get one blue led, sometimes no leds. I would remove the minimosd and it would work. Lately the boot freeze has been happening more often, even without the minimosd attached. Usually if I power cycle 10-20 times it will boot.

After reading this thread I have tried removing the dataflash card. So far, every time I boot it without the dataflash in (minimosd or no minimosd) it boots fine. I put it back in, and it won't boot. I suspect my dataflash card because I have other problems with it: sometimes I will come home from a flight and find no telemetry has been collected.

I hadn't really tried the reset button much, but at least for flights this morning it was solving the problem. Whenever the dataflash is in, I get a solid blue light, and then when I hit reset it boots up OK.

I have the same exact problem.

APM2 board, every time I boot it stays stuck on blue light, no red light. With a reset, it boots fine. 

I just got Xbees yesterday. Had not seen this before the Xbees. 

I have a similar problem with a new APM2

I have managed to write the firmware and do the initial setup of the APM2 board but when I power down and the power up with just the battery it refuses to start up. I have power coming in on the Output rail and the power is 4.95 VDVC. If I measure the power at the input rail and the analog rail I get 4.68 VDC. I ran a jumper between the input rail and the output rail but same thing.

This is what I see, hook-up USB to the APM 2 and the unit starts to blink and eventually you get a lock C and a 3DFIX. I do not connect Mission Planner. I have tried the same with a USB battery but nothing. Next I hook up the main battery and turn on the transmitter. I am now able to arm and run the motors I can also disarm the motors. Now I disconnect the USB cord and everything continues to function, arm, run motors, disarm.  Now I disconnect the main battery wait a few second then hook up the main power. Nothing just a blinking 3DFIX and a solid green power indicator.

I did try removing the SD card and it does seem to boot but when I put it back in it will not boot.

Any ideas?

Anything new about this topic ?

I've sent back my board to 3DR, it came back with a new shield, the dataflash card doesn't seem to move in its slot anymore. We had a successful mission, and on the second one, GPS fix problem appeared again. 3 hours in the field of extensive testing... of course when only connecting the board with USB, fix happens in seconds (like always)... When powered from the ESC's BEC on the output rail same problem with satellite acquisition... The first mission (earlier today) was executed with strictly the same protocol, the bug reappeared after battery change. We also changed our ESC (which after all  was working alright) for a $65 one with integrated 5A S-BEC.

Conditions were perfect : clear, open sky, no trees of whatsoever around, cell phone on the ground was able to get a lock to 10 sats, APM2 did catch 7 or 8 when plugged to USB (and GPS fix), on the lipo it went up to 5 without getting a fix.

We've tried everything, with or without XBees, we unplugged everything (current sensor, airspeed sensor, Rx, etc) nothing changed.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service