No data from mag (according to the graph)

Group:



Yesterday in a series of test flights, my airplane with a 2.5 APM struggled to find way points and at some times even the direction to go.  In effort to diagnose the problems I notices there was no mag data on the graph.  Am I looking this correctly?



Attached is a graph of throttle and mag data.  



What suggestions do you all have for me to correct this?



Thank you.

Bret C

Mag Log No mag data 030113 Bret C.jpg

2013-03-01 14-43-45.tlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Guys:

    No further help is needed on this thread.  I learned today the real problem is the fact that when the mode is switched to AUTO, the APM actually goes to RTL even though the HUD display on the Flight Data of the mission planner says otherwise.  Go to this thread for information about itl

  • THIS may be a factor in some of the information of a playback of your log.

    That is from the Arducopter section but it may apply to Arduplane as well.

    Let us hope one of the active plane folk jump in.

     

    3692639596?profile=original

     

    In the above pic, it looks like the aircraft was heading for an impact.

    The compass display did change as the flight progressed.

    3692639719?profile=original

    Nice flying site!

    -=Doug

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…