No Heartbeat Packets Received with 3dr 915MHz modules

I have recently bought the AMP 2.5, with the 900MHz 3DR radio and I have yet to be able to connect the APM to the ground station with the arducoptor code.  I know that this is not an issue with the radios themselves as I have been able to connect through the groundstation using the latest ardurover code.  With the latest Arducopter FW (2.9) loaded on the board, I was able to verify to verify that the 3dr modules are connected (both green LEDs are on, no blinking), but I am unable to set up a MavLink connection.  The error I am receiving when trying to connect is "No Heartbeat Packets Received."

I have attached a screenshot of the error details and a screenshot of my radio settings from the mission planner. The min & max frequencies are set correctly according to the Wiki, and everything else is set to default. Has anyone experienced this same issue? Any help with this issue would be greatly appreciated.

ErrorDetails.png

radiosettings.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Here is my experience with the same problems.  I scoured the net looking for solutions for the past two days.  I couldn't get a link like I had when I first connected.

    Well.  I had changed out my micro usb cord for a longer one. and all of a sudden no bueno! It took me these two days to figure out I was using a charger cord and not a data capable cable.

    Switched out the "usb" cables and boom there she was!

  • Necro bump, but I figured I'd add my solution to the pile since this post is at the top of Google search for the same problem I was having.  These were v1 radios and this was with an APM 2.5 board.  Both radios showed up in 3dr radio configuration, although I did have to update my ftdi drives to get the computer to recognize the ground module.  Serial rates set at 57 as per the documentation and com port also set to 57,600 baud.  I couldn't get the ground station to connect to the air radio.

    It wasn't until I started testing continuity between the different lines that I discovered that the tx crimp on the apm side had failed.  So I snipped that off and recrimped on a new one and everything fired up on the first try.  6 hours of troubleshooting to fix a crimp pin - it's always the silly things.. 

    I did, as a consequence of this troubleshooting, update the sik radio firmware to 1.9 (from 1.5) so I have that going for me which is nice.  I did all this in Mission Planner btw because try as I might I'm having a tough time navigating APM Planner 2.

  • Like you I get a full OSD on my goggles and both radios are working perfectly and I have checked the connections to each point of the three cable ends tried switching the tx-rx at the minim end APM end and NO info is yet to grace my screen.

    I'm going to try the "Buffer" Fix as I've tried every other fix I can find and I'll come back if there is any change.

    My OSD is the Mavlink 2.0 version from bangood however I just put on the latest Micro OSD from Hobbyking and this connected up with cabling that came with it and it's just the same full minimosd-extra layout updated firmware and character set but the only animated indicator on screen is the mavlink winker which I think is starting to laugh at me!.

    Three days so far and counting if anyone at all has any! idea on a fix Please wade in there's a beer in it for anyone with THE fix.

  • You awesome, Bill! Killed about 3hrs and changed 2 wires TX/RX aaand it works!

  • Hello,

    I have still been unable to get telemetry data from my APM to the ground station software with the 3DR radios. 

    Recently, I noticed on the xbee page of the wiki (http://code.google.com/p/arducopter/wiki/APM2Wireless) there is a section on using UART2 as the telemetry port. I figured it was worth a shot to try, so I did as instructed and broke the solder bridge on the back of the board and soldered together the UART2 pads. I initialized UART2 to a buad rate of 57600 inside of APM_Config.h and noticed that there was already the lineFastSerialPort3(Serial3) in the main ArduCopter file.  When trying this I am now hit with the original issue of no heartbeat packets found.  Is there more configuration needed to use UART2 as the telemetry port? the wiki seems very vague on what, if any, changes need to made in software to accomplish this.

    Or, is there anything else I can try to get telemetry data from my APM over these 3DR radios?

    Thanks,

    Ben

  • I had the exactly the same problem.

    The issue was that the soldering on the APM 2.5 radio connection was bridged from 5v and tx, only slightly but scraped between all the connections and the connection was finally there.

    Thank you all for posting here it all helped me find this issue. 

  • As mentioned above, I have tried to connect the radio to the UART0 pins on the board as opposed to the radio port and have been able to successfully connected to the board, however this is at a baud rate of 115 not the 57 that the radio config says to use. However, when I am connected I am not receiving any telemetry data in mission planner.  I looked through the code and manually set UART0 to use a baud of 57 and was again able to connect to the APM but this time with the correct baud rate of 57, but I still am receiving no telemetry data from the APM.  When opening the terminal I am seeing something similar to "Qq?Q?Q<QoQ?QA?".

      Is there anything else I can try to get this to work? Or is there anything extra I need to do to be able to read roll/pitch/yaw over the radio?

  • Try the AUTO option in the top right corner COM settings. I was having the same issues but it is now connecting. I think this is a new option as I dont recall seeing this on the older version.

  • I am also experiencing this with my APM 2.5 (i believe that's what you meant with "AMP 2.5") that I purchased last month.  Looking through the forums, it seems that there are some issues with getting the 3dr radio modules to work, but none of the solutions proposed fixed my issue.

    Has anyone else run into this issue?

This reply was deleted.

Activity

Abdulatif Tlaib liked Ryan's profile
8 hours ago
DIY Robocars via Twitter
RT @SmallpixelCar: First time at @wsraceways. After tuning @HokuyoUsa lidar signal and camera sensor on @NVIDIAEmbedded, my car was able to…
Sunday
DIY Robocars via Twitter
RT @breadcentric: The handy bit about racing with self-driving cars is that one can type while the car is racing. Report from #AWSDeepRacer…
Jun 18
DIY Robocars via Twitter
RT @chr1sa: Our Bay Area @DIYRobocars meetup is now at 2,700 members. Next in-person events (in Oakland) are training day on July 17 and…
Jun 18
DIY Robocars via Twitter
Videos from the ICRA autonomous racing workshop are now available: https://linklab-uva.github.io/icra-autonomous-racing/
Jun 10
DIY Robocars via Twitter
RT @SmallpixelCar: Prepared race track for Warm Spring Raceways @wsraceways and looking forward to test my new car at RAMS RC @ramsaicar fa…
Jun 6
DIY Robocars via Twitter
RT @f1tenth: Trying out some nasty blocking maneuvers 🏎️🤖 #f1tenth #autonomousracing https://t.co/nMTstsaogM
Jun 5
DIY Robocars via Twitter
May 27
DIY Robocars via Twitter
RT @araffin2: I will talk this Saturday from 18:00 to 19:00 Paris time for the @diyrobocars community about learning to race in hours using…
May 27
DIY Robocars via Twitter
RT @a1k0n: Luckily the infeasible hairpin problem was easily reproducible in simulation and I could test the fix before bringing the car ba…
May 26
DIY Robocars via Twitter
RT @a1k0n: Another problem was that I was over-constraining the car's allowed accelerations, so it didn't think it could turn as tight as i…
May 26
DIY Robocars via Twitter
RT @a1k0n: Breaking the map up into two halves worked, but I had to be more careful about separating the inner track from outer. There's se…
May 26
DIY Robocars via Twitter
RT @a1k0n: Here's a datalog for my fastest lap of the day. Lap timer is tiny window lower-left. https://t.co/myrlWWrKUY
May 26
DIY Robocars via Twitter
May 26
DIY Robocars via Twitter
RT @a1k0n: Here was my car's POV. Man this track is confusing in first-person! After the incident my camera was all scuffed up and I was af…
May 23
DIY Robocars via Twitter
RT @circuitlaunch: Loved seeing so many familiar (masked) faces at Circuit Launch today for our first in person @diyrobocars in over a year…
May 22
More…