No Heartbeat Packets Received with 3dr 915MHz modules

I have recently bought the AMP 2.5, with the 900MHz 3DR radio and I have yet to be able to connect the APM to the ground station with the arducoptor code.  I know that this is not an issue with the radios themselves as I have been able to connect through the groundstation using the latest ardurover code.  With the latest Arducopter FW (2.9) loaded on the board, I was able to verify to verify that the 3dr modules are connected (both green LEDs are on, no blinking), but I am unable to set up a MavLink connection.  The error I am receiving when trying to connect is "No Heartbeat Packets Received."

I have attached a screenshot of the error details and a screenshot of my radio settings from the mission planner. The min & max frequencies are set correctly according to the Wiki, and everything else is set to default. Has anyone experienced this same issue? Any help with this issue would be greatly appreciated.

Views: 11497

Attachments:

Reply to This

Replies to This Discussion

Hey thanks for the fast replies!

Baud rate is set to 57600

Pins on the board (UART0) I have soldered myself, and I have can at least say that i have a connection between the rx/tx pins and the solder jumpers, so they should be fine.

the 3dr are a other story, but when I'm able to load the settings from both boards, shouldn't that mean that rx/tx pins must work? Otherwise where should it send/recive the data?

Maybe it's really the board, is there a way to test that? A kind of overall hardware test in the Terminal would be a great feature...

Did you connect RX from the radio to TX on the APM? and vice versa for Radio TX?

okay, I have some success to report.

Here is what I did.  I did what   andreas kellermann did above, although it worked for me.

Checked continuity from the DF13 connector to the plug at the radio.  All is good. Made sure rx was going to tx, etc.. all good. still no connection could be had.

I finally soldered 4 header pins to the UART0 section along the other side and connected to them properly, that is rx to tx etc..  SUCCESS!

SO I am not sure what is going on with the DF13 port, but mine is inoperable.  Even though I have good solder connections and continuity.  I just cut a hole in my 2.5 case for the "new" telemtry connection and I'll live with that.

If all else fails you might want to try that alternate connection.  Ofcourse be sure your radios are setup correctly to begin with.  the radio configuration tool is also a way to test your radios to be sure they are setup to talk.  But if you have a solid green light, they are probably working, I think.

Hope this helps someone.

 

Mack

Yeeees that solved it!

The trick seems to be the new mission planner + AUTO connect

thanks a lot!

As mentioned above, I have tried to connect the radio to the UART0 pins on the board as opposed to the radio port and have been able to successfully connected to the board, however this is at a baud rate of 115 not the 57 that the radio config says to use. However, when I am connected I am not receiving any telemetry data in mission planner.  I looked through the code and manually set UART0 to use a baud of 57 and was again able to connect to the APM but this time with the correct baud rate of 57, but I still am receiving no telemetry data from the APM.  When opening the terminal I am seeing something similar to "Qq?Q?Q<QoQ?QA?".

  Is there anything else I can try to get this to work? Or is there anything extra I need to do to be able to read roll/pitch/yaw over the radio?

Ben,

I had the Same problem, with my osd and telemetry. Wille looking for the solution for my osd i light have found the solution for my telemetry als well. Check thuis link: http://diydrones.com/profiles/blog/show?id=705844%3ABlogPost%3A7521...

À post by Sandro about the values of the SR3 lines solved my problems.

Ben

I had the exactly the same problem.

The issue was that the soldering on the APM 2.5 radio connection was bridged from 5v and tx, only slightly but scraped between all the connections and the connection was finally there.

Thank you all for posting here it all helped me find this issue. 

Hello,

I have still been unable to get telemetry data from my APM to the ground station software with the 3DR radios. 

Recently, I noticed on the xbee page of the wiki (http://code.google.com/p/arducopter/wiki/APM2Wireless) there is a section on using UART2 as the telemetry port. I figured it was worth a shot to try, so I did as instructed and broke the solder bridge on the back of the board and soldered together the UART2 pads. I initialized UART2 to a buad rate of 57600 inside of APM_Config.h and noticed that there was already the lineFastSerialPort3(Serial3) in the main ArduCopter file.  When trying this I am now hit with the original issue of no heartbeat packets found.  Is there more configuration needed to use UART2 as the telemetry port? the wiki seems very vague on what, if any, changes need to made in software to accomplish this.

Or, is there anything else I can try to get telemetry data from my APM over these 3DR radios?

Thanks,

Ben

Yesterday when I  loaded preset settings for my Maja the 3DR telemetry stopped working. I checked the values on the SR3 lines and they have changed, logic if you load a different setting by someone else. So I changed back the values to the following:

 SERIAL3_BAUD 57

 SR3_EXT_STAT 2

 SR3_EXTRA1 5

 SR3_EXTRA2 2

 SR3_EXTRA3 0

 SR3_POSITION 2

 SR3_RAW_CTRL 0

 SR3_RAW_SENS 2

 SR3_RC_CHAN 5            

 

Wrote them into the APM and restarted MP hit the connect button and where back online.

 

Ben

You awesome, Bill! Killed about 3hrs and changed 2 wires TX/RX aaand it works!

Like you I get a full OSD on my goggles and both radios are working perfectly and I have checked the connections to each point of the three cable ends tried switching the tx-rx at the minim end APM end and NO info is yet to grace my screen.

I'm going to try the "Buffer" Fix as I've tried every other fix I can find and I'll come back if there is any change.

My OSD is the Mavlink 2.0 version from bangood however I just put on the latest Micro OSD from Hobbyking and this connected up with cabling that came with it and it's just the same full minimosd-extra layout updated firmware and character set but the only animated indicator on screen is the mavlink winker which I think is starting to laugh at me!.

Three days so far and counting if anyone at all has any! idea on a fix Please wade in there's a beer in it for anyone with THE fix.

Necro bump, but I figured I'd add my solution to the pile since this post is at the top of Google search for the same problem I was having.  These were v1 radios and this was with an APM 2.5 board.  Both radios showed up in 3dr radio configuration, although I did have to update my ftdi drives to get the computer to recognize the ground module.  Serial rates set at 57 as per the documentation and com port also set to 57,600 baud.  I couldn't get the ground station to connect to the air radio.

It wasn't until I started testing continuity between the different lines that I discovered that the tx crimp on the apm side had failed.  So I snipped that off and recrimped on a new one and everything fired up on the first try.  6 hours of troubleshooting to fix a crimp pin - it's always the silly things.. 

I did, as a consequence of this troubleshooting, update the sik radio firmware to 1.9 (from 1.5) so I have that going for me which is nice.  I did all this in Mission Planner btw because try as I might I'm having a tough time navigating APM Planner 2.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service