No HeatBeats from Mavlink -- The Saga Continues now w/ PixHawk

Thought the problem was a potentially faulty APM 2.6 so unwrapped my PixHawk.  Same problem.

In MP, it connects and downloads the firmware.  Pixhawk then gives the successful happy song.  Select connect via Mavlink:

- starts 30 second countdown

- red connect changes to green disconnect

- timer goes to 0

- continues trying or doing something for another 1 1/2  minutes while countdown stays at 0

- then get No Heatbeat error.

In Windows 8, Device Manager, Com 5 is set to 115200, 8 bits, no parity, 1 stop bit, no flow control, FIFO buffers.

In MP, Com 5 PX4 FMU v1.6 (COM5) is selected.

Tried:

- restarting the computer

- connecting via a different computer (windows 7 and an older version of MP)

- four different USB cables plugging into different USB connections (getting desperate)

- different com settings

I'm beginning to think i'm in a no heatbeat black hole.  will see if i can setup the radio (but can i do that without mp?)

Views: 15670

Reply to This

Replies to This Discussion

If you have the telem module connected you have to power from the flight battery and USB simultaneously. USB alone won't provide enough power.

This happened again on another new Pixhawk. Agree with Leon, that my earlier problem wasn't a faulty GPS/MAG (I'll explain why later).  This is what just happened and how I think I fixed it.

After downloading the firmware ...

With GPS/Mag connected to Pixhawk.  CONNECT ... no heat beats

Pulled both connections to the GPS/MAG.

Then pressed CONNECT ... it connected; disconnected; Tried again.  it connected.

Attached 5pin to GPS/MAG.  it connected

Attached 4pin to GPS/MAG.  no heat beats

repeated the sequence and confirmed again that the 4-pin on the GPS/MAG was causing the issue again.

So with only the 5-pin connected to the GPS/MAG connected, told Mandatory Hardware that I was using a Pixhawk GPS/MAG.

Attached the 4pin.  it connected!!!

Then attached the 3DR OSD.  no heat beats.

Disconnected the OSD.  it then connected

repeated sequence to verify OSD issue. verified

With OSD disconnected, connected via Mavlink.

Plugged in the OSD while connected

Went into config to update the OSD

then disconnected Mavlink

then pressed CONNECT ... it connected!!!

The reason why I know it's not the GPS unit that I thought was faulty is because I swapped it out after this was all working and sure enough, Mavlink connected.

turns out it wasn't a bad GPS/Mag.  keep reading the posts because it happened again to the next Pixhawk I bought.

did you check the USB port is work?

My one is not work on USB, it works fine in radio.

Hello all,

I have the same issue. I have a pixhawk board, I could upload AC3.2 firmware but then I can't connect the board to the mission planner. I tried different things: connect/disconnect GPS/compass modul, tried on different USB port, even tried with separate power module but in the end all ended with no heartbeat packets received error message. I don't know what to do further. Please help if anyone can tell me what to do.

sometimes it's magic.  usually once you figure it out it keeps working.

i'd call/e-mail 3DR customer service if you feel like you've tried it all.  they are responsive.

Thank you, I'll follow your advice.

I haven't got support from 3DR, but after reading other posts on the forum, I decided to replace the SD card. After replacing SD card, all things went well.

well done.

i wonder if 3DR checks for a heat beat before they ship them out or if they only do a direct connect?

i have done all above and i get the following on win 10

fail to create log...wont log this session  and then i get the usual no heartbeats......

the funny thing is that i have done this before i had few difficulties connecting but something happened and connected...i thing i played with the b rate 38400 to 57600..........any ideas

ok

i found this solution

nothing wrong with gps or any other ..

i connect lipo to the FC wait couple seconds then connect the usb cable 115200 and putting the right port connects to mission planner right away......then ready to setup

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service