Cant seem to get an answer. I will paypal someone $20 if they can help me solve this. Im serious!

I'm at my wits end here. I've put out 4 posts for help in the forums and no one has responded. I've written 2 developers and no response. I will literally pay someone $20 if they will take the time to help me understand what I'm doing wrong.


I have a single axis gimbal in my airplane for roll stabilization. It works well. I want to rotate the roll axis before landing to protect the lens during landing. I want to add a DO command after the last waypoint to change the gimbal from stabilized to retract. BUT, I cant make it work.

Heres a video explaining my problem. Please watch it and if you can assist me in solving this, I will make it worth your time.




This video explains my issue quite well (I think):

Views: 480

Reply to This

Replies to This Discussion


Even bribing with money doesn't work...

Hi Matt,

ive played some time with the arduplane cam mount, but iam not involved or fully understand the latest code (just using).

So, i will try to give you the simplest answer that comes in to my mind.

scenario: If you setup your mount to stabilize (like you) and fly.. then in the middle of the flight with the point cam here future (mavlink targeting) hit a spot..  then you are unable to return at stabilize, or rc targeting, until you go back to parametres and set it... i think this is why you cant DO, while change mount mode. Im sure this should is for devs to explain or on they way to fix, but here is a simple solution. 

set your mount at rc targeting,  which still has stabilization.assign a nob for roll and just before land move it to full bank.

of course iam not sure if this works at auto, but its easy to try.  Next idea, add an tiny servo to close the hatch and add this servo as retract. on the mount menu.

Tell us how it goes

Having a quick look at the code, MOUNT_CONFIGURE looks like it triggers the MOUNT Library to save the new mode, but it does not trigger the change. It looks like you need DO_MOUNT_CONTROL to actually get the servo positions set. So you need two commands to enact the change over mavlink.

I still not sure if there is still an issue with ArduPlane even recognizing the commands to send to the MOUNT library (hence your error) I'll look later.

Thanks Bill.

I tried adding control, with a roll value of 25 degrees in the 2nd input box, then added configure after it, and then a dummy waypoint. Still got an "error, Configure is unsupported" popup. The removed configure and tried only Control command. Got the same error but it said Control is unsupported.




James, thanks for the reply. ive tried rc targeting, but I get extreme servo jitters an erratic movement. all smooth with just stabilization, but as soon as I introduce rc control it has a mind of its own...

any ideas?

Ok, this caught me out. If you send a MAVLINK message from a GCS it will obey. If you write a set of WayPoints as a missionscript, it's not implemented. Not sure why not. Though it should not be a huge effort to implement.

/// Set mount configuration, triggered by mission script commands
void AP_Mount::configure_cmd()
// TODO get the information out of the mission command and use it

/// Control the mount (depends on the previously set mount configuration), triggered by mission script commands
void AP_Mount::control_cmd()
// TODO get the information out of the mission command and use it

i had the same problem, with the APM 2 board, were by design, the telemetry cable was too close to outputs 7,8 that i was using for my cam and telemetry cable touched mount servo cable, with some ferrits and carefull arrangement the cables, the problem gone...  oh, did you  set the input channels to desired ones?? its tricky some times, because you have to think rx output-apm input-apm output.. 

told you so for the mount configure think :)... still waiting for an update from Devs. or combined a special button from Michael O.  To configure directly from HUD after mavling targeting, or from commands. Like Bill said its should be easy. 

I quited the mount idea, for mapping because its not needed unless its superfast and accurate and it also adds failure points to the system. Furthermore oblique images produce better point-clouds.  But its perfect for filming, fpv, target tracking, surveilance etc..   make some flights with just the stabilization and then decide

I did setup the input correctly, the roll servo does respond to control from the transmitter, but it goes crazy while responding and is in no way useable like that. weird.

Thanks Bill.

I guess my next question should be:

Is this something that the dev team can put in as a fix? Or do I need to inform them of the issue?

Its frustrating only because I have the plane ready for its maiden flight and can't until I can get the darn servo to roll on command :)

Thank you Bill!!!!

Ill keep an eye on it to see if it gets fixed.


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service