Hi folks,

APM2.0

I tried updating the firmware (3.0) and it failed. It seemed to leave the old 2.9 on though as I could still fly and connect.

I cleared the eprom through terminal and tried again. Failed again.

It downloads the firmware and then seems to freeze.

I can upload my own sketches to the APM so it seems fine.

See screen shot of when it fails.

fail.png

I've tried from two PCs (both ok in the past)

Multiple USB cables

without the GPS and flashcard in

no XB connected.

Any tips appreciated.

Thanks

Crispin

Views: 277

Attachments:

Reply to This

Replies to This Discussion

Quick update - 

I can upload firmware (3.0.0) by compiling the code and uploading that. Worked without hassle. I can then connect with MP, view params, see HUD etc so all is peachy. 

I then try upload 2.9b or 3.0 through MP and nothing. Same as before.

Something is fishy with the MP way of uploading?

Obviously you've got the com port and speed set correctly on the top right of the mission planner's firmware screen?  Speed should be 115200 of course.

Disable bluetooth.

Sorry for the fast response. Didn't know if I would have more time to get back on tonight. 

I have had this exact problem multiple times and it can always be fixed (for me) by disabling blue tooth or anything else at the driver level that is creating virtual serial ports. 

If the serial port list in the upper right corner of the MP takes forever to refresh or lags badly on opening it's a good sign that you will have this problem. 

It seems to be a MP bug that was introduced in the last few weeks or perhaps a Windows patch has caused it. 

I hope this helps! 

@ Randy : yup, all correct.
@ JB: thanks! That's the most annoying thing out. Will try and see.

Not my issue though as I've had the sluggish serial or a few months. Failure to upload FW is recent.

Thanks all.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service