Hi guys,

am I stupid or what's wrong? Building up the APM was easy, all sensors and outputs work fine. But why I cannot read a single input from the receiver? Tried >10 different firmwares and tested 3 different receivers with the APM -> test -> pwm, no valid input on all 8 input channels. APM is V1.4, it is connected with USB and has a BEC on Output 3. MUX-LED is always yellow and PPM-LED pulses all the time. The readings are always 1200 in each and every case.

Anyone could help? I cannot believe that the board is defect when all other things are perfect. Readed dozens of threads and wasted hours for debugging. :(

Best regards, Thomas

Views: 1364

Reply to This

Replies to This Discussion

Chris, if you guys find out what the problem was ... - could you please share that info with us? Maybe there is an easy solution. Thank you, T.

I'll see if I can find someone with a different transmitter, I bought the Aurora because friends have the same set-up and are very happy with it. In order to test whether it might be a receiver issue, I tried to connect (only) a joystick through the Planner. The result was (almost) the same as with the receiver; moving of the joystick along the x/y/z axis and the throttle were not sensed, but strangely the buttons on the joystick worked fine. I found it a bit odd, as it would suggest a software issue, but don't know enough about the Planner or the APM to make any sense of the info.

Either way, when I detached the receiver and I put the plane in "Stabilize" mode all the servos twitch and the PPM light never turns on. That would seem to exclude a receiver compatibility or software issue. Or am I misinterpreting?

What code have you loaded? ArduPlane 2.24? We're not seeing any of these issues. There is no connection between joystick inputs in the MP and RC inputs in APM. 

Strange... Once I started having issues I made sure to update the code and the planner. At last check I was using ArduPlane 2.24 and Planner 1.75. I'll re-flash the code, download 1.76, retry the joystick and the APM and report back. 

Ok Chris, in full "debugging mode" I installed a clean Win 7 Home on a netbook I wanted to use in my groundstation and got to testing. I flashed the ArduPlane code and installed Planner 1.76. For joystick issue I plugged in an MS Sidewinder and a Logitech rumblepad to eliminate a hardware issue in one or the other.



1) APM not sensing Rx input

No luck here after flashing ArduPlane. PPM LED remains permanently off. Without RX attached servos twitch. With RX attached, signal goes to servos as if in [Manual] mode, but the APM senses nothing (1200 min and max on every channel when calibrating).


2) Joystick input not identified by MP

- Issue was replicated, but I have also figured out why: The "throttle" slider on the Sidewinder is "idle" at 50%, not at 0%. the Sidewinder sends a signal to MP that overrides any other joystick signal for some reason. The result after pressing [auto detect] is detection of "Slider 1", irrespective of what you do with the joystick. Putting the throttle at 50% PM senses all the Sidewinder's movements just fine, and the Rumblepad worked perfectly.

- Once correctly calibrated and enabled, moving either joystick did not result in the output indicator for any of the 4 channels changing, however. Or cause any reactions by the servos for that matter. This is consistent with the Rx-APM hardware issue above.

Thanks for the update. 


1) If you can't test it on another RC brand, I don't know how to diagnose further. I suggest you return the board and see if that makes a difference

2) Good update--glad you sorted out part of that at least. The reason you're not getting servo output is because radio calibration hasn't been done because of problem 1.

Chris, I have a colleague with an EzUHF Tx/Rx (attached to an Aurora, but that should not matter I believe). Would that be sufficient to test it with?

Despite the issue with this particular APM, I am frankly so impressed with it that I am considering buying a second for the SuperCub my collegues gave me yesterday. Have there been many issues with the Aurora?

I'm afraid I don't know what an EzUHF is, but it's worth a try, at least to eliminate the Aurora as the issue. I haven't heard of other issues with Auroras, but I don't have any way of knowing how many have been tried. I use Futaba and Turnigy, which have never had issues. The Spektrum gear has some funky pulse width issues that sometimes need to be set on the Tx (we discuss this in the manual), but otherwise work fine. 

Hi Robert,

I'm not sure if it has already been suggested, but if the blue LED on the APM board no longer turns on when the board is powered, this likely indicates a hardware failure.

Chris, techsupport mentioned that it was a bad firmware on the 328. Which is what we were suspecting. They reflashed and say it's working great now.

My only issue now is they want me to pay for return shipping. The 328 isn't something that's readily flashed and I thought it was supposed to be working when it left the shop. I'm well outside my 30 day window but really thought this was we'd work with.


It's only 9 dollars to ship back and me making a big deal probably isn't right, but ..... ya know.. kinda stings.. I did pay to send it in..

I presume they mean it was corrupted firmware--ie, something happened in use to damage it after receipt. All those boards are tested and pass QA before they're sent out. 


But if you'd like me to Paypal you $9 anyway, please PM me your email address.

Reply to Discussion


Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service