No throttle control on arducopter

Hi

I am a complete noob at this, I have built a octo using APM 2.5, my problem is the throttle seems stuck, it starts up at a high speed but when you try to increase it just stays at the same speed.

 

I think I am having the same problem in this thread, tried everything and still cannot get it to work, Any help please.

http://diydrones.com/forum/topics/problem-no-throttle-control-on-arducopter-2-9-1-quadcopter-3dr?groupUrl=arducopterusergroup&xg_source=activity&groupId=705844%3AGroup%3A394475&id=705844%3ATopic%3A1118715&page=1#comments

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Well it's 2 AM in ABQ and I swear my APM is possessed. EVERYTHING is working again. Arm/disarm and all.

    I DID NOT change ......oops...yes I did.

    I put a new GPS on the APM. I reloaded firmware 3.0.1 and the thing that got everything working was..............

    Going to the setup or test mode, I forgot which, and did an ERASE. After erase I reloaded FW. All this fu..king around for 3 days and it appears to have been something in the flash memory. From now on when I reload FW I will do the erase first !

    Anyway....things are working and I am going to fly tomorrow after a GOOD nights sleep.

    Earl

  • Problems here also...

    Here are my throttle ranges etc.

    Throttle range on input Ch3 990 - 2015 armed or unarmed.

    Outputs with throttle disarmed:

    All Ch 1-4 at 987

    Outputs with throttle all the way down armed condition:

    Ch1 1199

    Ch2 1171

    Ch3 1119

    Ch4 1227

    Outputs with throttle at mid position armed condition:

    Ch1 1435

    Ch2 1321

    Ch3 1372

    Ch4 1513

    Outputs with throttle all the way up armed condition:

    Ch1 2010

    Ch2 1901

    Ch3 1605

    Ch4 1750

    Quad level as I can see and on Mission Planner HUD looks level.

    Still can't Arm/Disarm with RC, must use MP

    Earl

  • I can't even ARM or DISARM with the RC throttle. I have to use the Mission Planner to ARM/DISARM. Once armed, I have full control from 5% to 100% throttle.

    I have been working with Mark at 3SR to solve the problem.

    No luck yet.

    My setup:

    APM 2.5

    Firmware 3.0.1

    DJI Phantom shell

    Power distribution board from 3DR

    900mhz 3DR radios

    8000 mah battery

    Turnigy 2822/17T motors

    FS-TH9X RC

    Rmilec 1.5 watt tx and companion rx

    I hope to get it fixed.

    Earl

  • My low throttle is 1100

    at 1103 the motors start and will ramp up in speed as it sits there.

    Running with no props is different from actual use.

    I have linear increase in motor speed up to the max of 1900 on throttle. All settings are the default 100%.

    Have you tried changing the THR_MIN parameter as I found with some motors, especially at 1200kv, that it was too high and lowered it to 70 with good effect, but do read up on the consequences of doing this.

    On some ESC's I have also set MOT_TCRV_ENABLE to false to disable the throttle curve to give better linearity to the motor speed.

  • I was wondering why you selected manual timing instead of auto, was there some instructions with the ESC's to work with those motors?

    It does look like an ESC problem, but note that the output of the throttle is not a linear representation of your throttle input.

    For instance, you will not get full throttle even with the stick at full, as there has to be some % left for the controller to still stabilise the craft.

    The main issue I see is this having to give it 20% throttle to get the ESC's to spin.

    In the radio calibration page what is the PWM range of your throttle?

    On your Tx what is the travel range for your throttle, -100% to 100%?

    Are there any sub trim settings? Anything else in the Tx that might be causing this?

    As an example, I fly all Hexa's from a single factory default Tx Acro setting. The only changes in the Tx was the mixing for flight modes.

  • What firmware have you loaded?

    What calibrations have you done?

    Can you post a log file?

    Providing more information allows for a more complete picture of what is happening.

This reply was deleted.

Activity

xemone liked Max Gilson's profile
Aug 31
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
DIY Drones via Twitter
RT @MarvelmindMaxim: Extreme precision for 60 swarming robots. #marvelmind #autonomousrobotics #robotics #swarmrobotics #rtls #ips #indoor…
Aug 3
DIY Drones via Twitter
RT @MarvelmindMaxim: Precise (±2cm) tracking for racing boats and autonomous boats. Works outdoor and indoor. #autonomous #AutonomousVehic…
Aug 3
DIY Drones via Twitter
RT @MarvelmindMaxim: Helping PixHawk folks to fly autonomous quadcopters using PX4 and ArduPilot. https://marvelmind.com/drones/ Equally suitab…
Aug 3
DIY Drones via Twitter
RT @davsca1: Here is the video of the performance. This paper was a huge group effort and more than one year of work, where we combined and…
Jul 16
DIY Drones via Twitter
RT @chr1sa: My talk on PX4 and FAA certification is coming up at 1:45 PST today on the PX4 Dev Summit livestream. Includes some cool new st…
Jul 7
DIY Drones via Twitter
RT @seesharp: I'm tuned into the PX4 / Dronecode free live conference. Great stuff. Microsoft AirSim talk in 10 minutes. https://t.co/0zbZ2…
Jul 6
DIY Drones via Twitter
RT @chr1sa: Here's today's best times in the @DIYRobocars/@donkey_car virtual race of AI cars compared to last month's race on the same tra…
Jun 20
DIY Drones via Twitter
Jun 19
DIY Drones via Twitter
The difference between proper RC cars and toys (when you’re turning them into robots) https://ift.tt/2MUTvxd
Jun 14
DIY Drones via Twitter
RT @Struktur3D: We have just posted on @DIYDrones for the first time in a long time. Continuing with our search for a #lasercutting service…
Jun 5
DIY Drones via Twitter
Review of the new Nivida Jetson NX for robocars https://ift.tt/36TrS0G
Jun 2
DIY Drones via Twitter
RT @chr1sa: Somehow I missed this, but last week @Nvidia released a new version of its Isaac robot development framework. Lots of new Lidar…
May 31
DIY Drones via Twitter
Welcome to the new DIY Drones design!. You may have noticed that DIY Drones looks a little different today. That's… https://twitter.com/i/web/status/1265714415137153024
May 27
DIY Drones via Twitter
New! Online Training on Drones for Disaster Response https://ift.tt/3ehdHoT
May 26
More…