I am a complete noob at this, I have built a octo using APM 2.5, my problem is the throttle seems stuck, it starts up at a high speed but when you try to increase it just stays at the same speed.


I think I am having the same problem in this thread, tried everything and still cannot get it to work, Any help please.


Views: 1368

Reply to This

Replies to This Discussion

Yes the green throttle bar moves up and down in mission planner.

I will try to explain a bit clearer.

Let's just say that when I push the throttle up the motors start to spin up at 20% throttle then the rpm goes up to 40% but from 40% to 100% throttle the rpm seems to be the same.

When I put the props on and started her up it tried to take off and that was at 20% throttle where the motors just start to spin up.

Bruce, I'm no expert but it seems like an esc calibration problem, what esc's are you using, did they come with a kit for the octo?

These are the ESC's http://www.hobbyking.com/hobbyking/store/uh_viewItem.asp?idProduct=...

They did not come with a kit, I did the auto calibration again last night and it runs through all ok.

I origanally calibrated the ESC one by one but last night I ran the auto calibrate on them and it's still the same. Would the wrong programming settings cause it to run like this, see pic below, these are the settings I used with that programming card.


I was wondering why you selected manual timing instead of auto, was there some instructions with the ESC's to work with those motors?

It does look like an ESC problem, but note that the output of the throttle is not a linear representation of your throttle input.

For instance, you will not get full throttle even with the stick at full, as there has to be some % left for the controller to still stabilise the craft.

The main issue I see is this having to give it 20% throttle to get the ESC's to spin.

In the radio calibration page what is the PWM range of your throttle?

On your Tx what is the travel range for your throttle, -100% to 100%?

Are there any sub trim settings? Anything else in the Tx that might be causing this?

As an example, I fly all Hexa's from a single factory default Tx Acro setting. The only changes in the Tx was the mixing for flight modes.

Thanks Mike

No instructions came with these but I found a few posts on hobbykings site and a few people said that those were the settings they used so I copied them.

Throttle range 1100 to 1898

1100 right down to the bottom
1138 motors start
1364 rpm doesnt rise until you hit this figure and stays constant to full throttle which is 1898

On your Tx what is the travel range for your throttle, -100% to 100%? is it travel adjust? if so this is the range  L100% to H100%

everything else is as it was , I have not changed anything.

My low throttle is 1100

at 1103 the motors start and will ramp up in speed as it sits there.

Running with no props is different from actual use.

I have linear increase in motor speed up to the max of 1900 on throttle. All settings are the default 100%.

Have you tried changing the THR_MIN parameter as I found with some motors, especially at 1200kv, that it was too high and lowered it to 70 with good effect, but do read up on the consequences of doing this.

On some ESC's I have also set MOT_TCRV_ENABLE to false to disable the throttle curve to give better linearity to the motor speed.

Thanks Mike

Some headway made.

Now that is strange, I disabled MOT_TCRV_ENABLE and it didn't make any difference so I re enabled it and now my motors start up slowly at 3% throttle, I then push the throttle to 20% and it picks up right through to full throttle, so is it supposed to be dead from 3% to 20%

I can't even ARM or DISARM with the RC throttle. I have to use the Mission Planner to ARM/DISARM. Once armed, I have full control from 5% to 100% throttle.

I have been working with Mark at 3SR to solve the problem.

No luck yet.

My setup:

APM 2.5

Firmware 3.0.1

DJI Phantom shell

Power distribution board from 3DR

900mhz 3DR radios

8000 mah battery

Turnigy 2822/17T motors


Rmilec 1.5 watt tx and companion rx

I hope to get it fixed.


Problems here also...

Here are my throttle ranges etc.

Throttle range on input Ch3 990 - 2015 armed or unarmed.

Outputs with throttle disarmed:

All Ch 1-4 at 987

Outputs with throttle all the way down armed condition:

Ch1 1199

Ch2 1171

Ch3 1119

Ch4 1227

Outputs with throttle at mid position armed condition:

Ch1 1435

Ch2 1321

Ch3 1372

Ch4 1513

Outputs with throttle all the way up armed condition:

Ch1 2010

Ch2 1901

Ch3 1605

Ch4 1750

Quad level as I can see and on Mission Planner HUD looks level.

Still can't Arm/Disarm with RC, must use MP


Not sure what your describing here, are you saying the motors start at 3% then stay the same until 20% where they go to full throttle?

Just had a thought, as the question is really about how linear these ESC's are, and having the HK brand I tend to suspect them first.

Why not stick a servo on a Y lead to one of the ESC's, or even in place of, and see if the output from the APM is linear, or it jumps. This will at least tell where the problem lies, in the ESC or the APM.

Well it's 2 AM in ABQ and I swear my APM is possessed. EVERYTHING is working again. Arm/disarm and all.

I DID NOT change ......oops...yes I did.

I put a new GPS on the APM. I reloaded firmware 3.0.1 and the thing that got everything working was..............

Going to the setup or test mode, I forgot which, and did an ERASE. After erase I reloaded FW. All this fu..king around for 3 days and it appears to have been something in the flash memory. From now on when I reload FW I will do the erase first !

Anyway....things are working and I am going to fly tomorrow after a GOOD nights sleep.


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service