No Video or Connection Between Solo Gimbal & GoPro Hero3+ Silver.

Hello folks,

so after a nightmarish event of dealing with 3dr, I finally received my gimbal and attempted to install it.

The installation was acceptable, I won't say it went smoothly because, that simply wouldn't be true (the wires definitely could of used more room, or at the very least better placed.

All systems have been updated, including the go pro. I

So upon placing my GoPro Hero3+ Silver (3.02) into the gimbal and powering everything on according to the instructions included by 3dr, I'm asked to update my GoPro firmware, which makes no sense considering I have the latest firmware version (GoPro also confirmed this), and upon dismissing this request, I'm met with a please plug in the hdmi cable screen, thus no video link. Further more upon shutting down the system my GoPro remains powered up, and completely frozen, requiring the lipo to be pulled from the go pro in order to reset it. I have also tried all capture settings (1080p,960,720) (60fps,30fps) (narrow, medium, wide) still causes go pro to crash.

Isn't the gimbal compatible with the Hero3+ silver? It does say in the manual that it in fact does support it fully, however at this point I have a hard time in believing much of what 3dr says.

Now after doing some research I came across a link on referring to other users experiencing this same issue, with the response from 3dr claiming it to be a bug that they are working on, and for the time being convert back to the GoPro 2.00 firmware. I myself asked 3dr such, and was simply referred to the online pdf of their included manual, which seems shady to say the least why some users are given a solution and others are simply pushed aside and routed back to the manual. 

So upon downgrading firmware (GoPro highly recommended against this I should note), I does still request the firmware on the GoPro to be updated within the Solo App, however upon unplugging and plugging back in the hdmi cable I now get video signal.

However the issue I'm now faced with is the inability to record onto my GoPro as I cannot access the record button due to the gimbal covering, and I can not control the go pro record/stop video the controller or app, and simply only being able to record directly on to my iOS device, which a subpar at best.

So does is anybody else having similar issues? If so have you discovered a solution?

Thanks in advance.

Views: 10962

Replies to This Discussion

Does anyone know where I can get the 2.0 firmware? 

Hi Kevin,

it's been a while now since I ran that particular update, as I've changed to the Hero 4 now, but you could give this a try, it should be what your looking for I believe.


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service