Have the AP Mega and IMU assembled, have done some basic tests to switch led's on/off etc.

One thing I can not get working and have trouble debugging is the ADC, all the test program returns is a row of 0's.

Any ideas how to debug ?

The code I used is the files as below for the libraries and APM_ADC_test.


Hein

Views: 265

Reply to This

Replies to This Discussion

John, contact DIY Drones tech support. All boards are tested at the factory, but they can walk you through a process to pinpoint what's likely a user soldering error. If that's not it, they can help diagnose.
Woohoo! Fixed it.  In case others see this issue, for me there was solder that shorted together pins 11 and 12 on the Atmel.  11 is ground and 12 is RX2 which is how the ADC sends data back to the Atmel.  Once I broke the solder bridge things worked fine :)

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service