This is a discussion of getting the PX4Flow sensor working with Copter-3.3.1 (or higher).

Views: 23067

Reply to This

Replies to This Discussion

Hi, can any body help me to connect the px4f

I struggled for days trying to setup the OpticalFlow with APM Flight Stack. Never worked. If you are using Pixhawk, then I suggest you switched the PX4 Flight Stack since it works flawless. See test video here: https://youtu.be/G7fGC4OmxO0

Instructions here: http://dev.px4.io/flow_lidar_setup.html

Hi,

Thank you AI B , you means that px4flow don't work with the mission planner?

I have px4flow v1.3.1. how can I physically connect them

../_images/OptFlow_Pixhawk.jpg

here we connect the I2C (12V) , in my Px4flow there is no 12 v but 5 v, then how can I connect them



Al B said:

I struggled for days trying to setup the OpticalFlow with APM Flight Stack. Never worked. If you are using Pixhawk, then I suggest you switched the PX4 Flight Stack since it works flawless. See test video here: https://youtu.be/G7fGC4OmxO0

Instructions here: http://dev.px4.io/flow_lidar_setup.html

Hi,
I am experiencing a problem when i try to use Lidar_lite and px4flow sensor with my pixhawk FC.,

When i activate px4flow , i am not able to use camera gimbal function.
Is this a common problem ?

Did anyone manage to set up AC 3.4.6 with PX4FLOW properly and did fly with it?

I am trying to fly (outside) with my quad (Copter 3.4.6) together with PX4FLOW and Lidar Lite V3 (no problems with lidar), however I am struggling due to problems with EKF2:

when I try to ARM my quad in Loiter Mode, or when I fly in AltHold and try to switch to Loiter mode, my quad does not allow me to do it (EK2 failsafe is triggered, so either land or althold). I am receiving commands: "EKF2: IMU0 HAS STOPPED AIDING" and "EKF2: IMU1 HAS STOPPED AIDING"

When I move my quad by hand, I can see that opt_m_x, opt_m_y and opt_qua readings are non-zero (opt qua goes to 255).

When I set back EK2_GPS_TYPE from 3 (Optical Flow) to GPS. the loiter mode works properly, without any EKF2 issue. I have tried AC 3.4.2 but the problem remains the same.

Best ask this at discuss.ardupilot.org

Hello,

I am working with the PX4 Flow and trying to connect it to a pixhawk mini.  For some reason, I can't find a scrap of documentation for anything related to the pixhawk mini.  So, I come to y'all!  The issue is that the Pixhawk mini is unable to the PX4 Flow camera being plugged into it's I2C port.  My setup/issues are as follows:

1.  The 4 pin pixhawk mini breakout cables for I2C did not fit the same 4 pin I2C connection on the PX4Flow, so I had to cut and sodder until we had a working set.  I do not believe this is the problem because I soddered everything 1 at a time.  

2.  Is the pixhawk mini incapable of having a PX4 Flow camera attached to it? Even if it is an I2C device?

3.  In Mission Planner, the box that one would click on to enable an Optical Flow sensor is greyed out.  How do I make that not grey-ed out essentially?  In addition, the value "FLOW_ENABLE" is not avaliable on the full parameter list.

I am following this documentation for the PX4 Flow: http://ardupilot.org/copter/docs/common-px4flow-overview.html .  The PX4 Flow is powered and has the most recent firmware.  Any help would be appreciated.  Also any pages related to the PX4 Flow and Pixhawk mini would be helpful as well! 

Thanks

All-

I documented my experience 2 summers ago with Optical Flow and Lidar on a Pixhawk. I spent a lot of time working on optimizing my performance, and learned a lot along the way. It's been a little while, but if you have any questions, ask!

My experiences

Hello. 

I have this problem and i am not alone, however i cannot find a solution.

I have 3dr pixhawk mini - PX4Flow - LidarLite V3.

On pixhawk i run the firmware 3.5.0 - rc11, because previous versions are not working with my pixhawk mini.

Because pixhawk mini has no input pins for PWM, i connected both sensor via I2C. Lidar is powered directly from 5V bec and PX4Flow from 3.3V on i2c bus. When i test both sensor independetly they work fine, both are working and both shows changes in status tab.

However if I power my board from USB first, only optflow is working. If I power my board from battery first, only lidar is working. 

What should i do? I cannot make them work both at the same time.


Well its not a problem with the adresses. Because, yesterday the lidar was powered throug separate BEC and Optflow via 3.3V on I2C. And it worked as I described it above. Today i tried to power lidarlite through Pixhawk mini 5v output on rc connector and: When i power the whole system first from battery, only Lidar is working. BUT when i power the whole system from USB first and then i connect it to battery, both sensors are working. So i guess its a firmware issue. Of course i could always power my drone from USB first, but thats not very practical at all and power consumtion of both sensors can affect my Pixhawk mini, so i dont want to power them from Pixhawk directly.

I have the same problem, and I know there are many people have the same problem.

I do find a solution so you might try if it works for you.

I guess this is a race condition during startup so I try to slowdown the boot process.

Here is my solution to this problem:

Create a file /etc/rc.txt on your pixhawk SD card with the following content:

if usb_connected
then
      echo "USB Power PX4Flow Should Start"
else
      echo "Sleep 3 secs, wait for PX4Flow"
      sleep 3   
fi

That solves the problem for me,

My Lidar lite V2 and PX4Flow seems to work well with AC3.5.0 when I test it today.

Good Luck!



Vaclav Demeter said:

Hello. 

I have this problem and i am not alone, however i cannot find a solution.

I have 3dr pixhawk mini - PX4Flow - LidarLite V3.

On pixhawk i run the firmware 3.5.0 - rc11, because previous versions are not working with my pixhawk mini.

Because pixhawk mini has no input pins for PWM, i connected both sensor via I2C. Lidar is powered directly from 5V bec and PX4Flow from 3.3V on i2c bus. When i test both sensor independetly they work fine, both are working and both shows changes in status tab.

However if I power my board from USB first, only optflow is working. If I power my board from battery first, only lidar is working. 

What should i do? I cannot make them work both at the same time.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service