Hello all, Recently I have completed my 250 build and I am having trouble tuning it. I started with P, then I, and finally tuned D till I like the timing of it's response. And I have it flying well in stabilization and acro mode. It hovers in a 5 foot radius with no problems but when flying and banking semi hard it has strong oscillation.

So my question is, are there any other settings I can change other then the pids to make it more stable. I feel like my pids are rock solid and this only happens when in turns or during hard foreword. When I bring the P or I down anymore it becomes sluggish and unresponsive.

It could be vibration but I put a thick amount of foam under both the flight controller and gps unit so I don't know what else I could do to dampen any more vibration, I even have all my props balanced.

SETUP:
250 quad frame
12a afro esc "flashed with latest BLheli"
multistar baby beast motors 
HKpilot micro master set

Any help would be much appreciated.

Views: 952

Reply to This

Replies to This Discussion

Go into your advance parameters settings and search for "FILT", short for the filter settings.

There will be a few FILT labeled options, maybe 3 or 4. One for Gyro, Acellerometer, and I think EKF rates and so on.

Set them all to at least 42(hz) and I think the settings allow for up to 100 hz. Try your hard maneuvering again and

it should be rock solid. The 250 frames, especially with stronger power options can correct the frame orientation

to what the flight controller wants, faster and slower at certain times, causing oscillation with the default 20hz setting

which you will likely find as being such. The default of 5hz for the yaw correction I have no advice on currently and should be fine to leave it how it is, but that may be something to be aware of down the road with other frame configurations.

(edit) Also I didnt consider the nature of the HK Pilot micro you have. If this is the APM hardware based flight

controller, I'm not sure how what I recommended to you would work. Your problem however, I have observed in PX4/ Pixhawk based hardware.

Thank You for the reply, I am trying this out rite now and will update with results. 

It seems there is only one option in the list for FILT and that is INS_MPU6K_FILTER and it is already set to 98. I set it to 100 but no difference what so ever. 

I uploaded the .bin file that i just did in my garage if that is any help.

Attachments:

Check this VIDEO from Dennis. I did also get rid of the full throttle on my 250 it's now rock solid, but if e.g. i change from 3s to 4s i have to tune the quad again :(

maybe there will be some kind of setting to store 2 pid values where you switch between those on the fly, would be a great feature.

Oh ok, probably because of older hardware. Try looking at your PID settings and look at the D values. Usually they are 0.004. Try reducing the pitch and role D values to 0.001 through 0.003 and take notice of any performance changes.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service