I just got my 3DR 433 mhz kit. But one of the radios seems to have a problem.


When i plug it into my computer using tha FTDI cable the green light stays on and the red one blinks once about every scond. The terminal says:


radio_initialise failed"


The hardware seems ok. I was able to get it into bootloader mode by shorting the CTS and ground. firmware was then updated sucessfully. My other "Air"-radio is fine and i can upgrade firmware in "AT" mode and configure it with APM planner. 

Im running:

Windows 7

APM planner 1.1.81 mav 0.9

Any suggestions?

Views: 2507

Reply to This

Replies to This Discussion

Is there a general way to unbrick these radios?

Hi kbcopter,

Here at 3DR we've seen one radio output the same panic message as yours, and from trying to unbrick that one I can say that reflashing the firmware won't fix it (uploading the bootloader again do it won't either, it's unrelated.)

you can contact help@3drobotics.com to get a replacement.


Hi kbcopter,

I've had this happen to me twice with these radio during the development process. The two causes were:

  • a bad ground connection (I was grounding the wrong pin due to a bad cable!). It worked fine when I fixed the cable
  • a wet radio after I 'landed' my quadcopter in a shrub after it had been raining. It worked again once I let the radio dry out

In both cases the radios would panic continuously on boot. After I fixed the causes they were fine.

The 'panic' messages happen because the 8051 doesn't get sensible replies from the radio module when it tries to initialise the radio. That does sometimes happen on a software reboot using ATZ if we've left the radio module in a bad state (ie. I probably don't have the reset code quite right), but it shouldn't happen on an initial powerup. If it does happen on initial powerup (which it seems to be for you) then its almost certainly a hardware issue.

As Sam says, you can send yours back in for replacement, but if you prefer to tinker a bit first, perhaps the above will help you work out what's wrong.

Cheers, Tridge

I seem to be having the same exact issue as you. Did you ever get it fixed or just a replacement?

I got impatient bought another radio:) was planning on returning radio but wanted to see if i could fix it, motivation gone when i got another radio that worked.

There are some other threads about similar problems, u tried suggestions in this thread : http://diydrones.com/forum/topics/3dr-433-mhz-radios-not-working ? 

....or just contact 3dr and get a replacement.


Hi gutzmann, the panic issue is usually caused by a malfunctioning HM-TRP module, which we don't manufacture. You can contact help@3drobotics.com to set up an RMA and get a replacement.


I can not get my 433 3DR radios to connect and I have tried everything I dont understand why the device ID is RFD900 when it is a 433 radio. I cannot fill in the Format box either by copying or manually and the second version box will not complete. Anybody got any suggestions


Alan: The second box is auto filled out when the two radios connect, which has not happened here. Are you sure you've got two 433 radios, and not one 433 and one 900? Where did you get them? 

I bought them direct from 3D Robotics.

They did work when I received them. I had them on the bench and only tried them a couple of times. They have not been flown, moved or had not been disconnected only the MP had been updated during this time. 

Please connect the "air" on the the FTDI cable and confirm that it has the same settings as the "ground" one that you read in the screen shot above. 

Thanks Chris, sorry to waste your time silly me I had number of channels set differently.

I will go and see the optician on Monday.

Hi, I'm getting exactly the same symptoms as the original poster on both (ground and air) of my radios.

These are the set I bought: http://www.goodluckbuy.com/index.php?target=products&product_id...

When powered the green LED is solid and the red LED flashes briefly (about 1hz)

Ground PCB says 3DR Radio USB v1.0

Air PCB says 3DR Radio v1.2

I've tried reflashing the firmware (which succeeds) by shorting the 3rd pin with ground to get the solid but neither respond to any commands and constantly print

**PANIC** radio_initialise failed on the terminal screen (correct COM port and 57600 baud selected) and doesn't respond to any of the AT* commands.

I've tried both the radio part of the latest Mission Planner and the 3DR radio tool.

I have contacted Goodluckbuy to request return (not that I hold out much hope)

I'm out of ideas, is there anything I can check hardware wise for continuity / incorrect wiring?


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service