Hi,

I was doing the first preliminary tests and was testing to see if everything looked ok.

Throttle, yaw, roll all works fine: if I move the stick the copter moves the way it should.

The one one that is reversed is pitch: with the front arm pointing forward, if I raise the stick, it pitches back (as in, coming toward me), while if I move the stick to the min, it pitches forward (like going away from me).

It looks like it's reversed, but it's weird because the radio configuration on the mission planner said it was ok.

Is there something wrong in the wiring up? I don't think so as apart from this little problem the copter looks like it's behaving correctly. Should I reverse the channel on the radio? or on the mission planner?

Or maybe it is correct that way and it's supposed to work the opposite way I think it should (stick up-raise front arm => pitch back, stick down-raise back arm => pitch forward)?

Thank you

Simone

Views: 27824

Reply to This

Replies to This Discussion

The easiest way to change radio channel direction is at your transmitter.

Thanks, I will have to look into that more tomorrow. I thought I did but when tried the quadcopter pitched the same way so will have to relook into how to change the pitch on my Dx7.

Any walkthrough of that would be great as I think I am missing something.

If you really want to change in the MP, look under the advance parameter list. Each channel has a number of options, one will reverse the channel. I don't have access to MP at the moment, but I believe you change the a value from 0 to 1 to change direction. Good luck and fly safe.

Interesting, answered this same question in another discussion to day already: http://diydrones.com/forum/topics/reversing-pitch?xg_source=activity

Mostly same as above though do it at your RC transmitter.

I had this same problem. I kind of went into a mild panic and landed hard :-(

As Rechard told you, the best way to change it is by reversing the stick orientation in the transmitter settings. If you change your wiring, you are gonna have much worse problem with other axis and it will be totally unstable.

Thanks for the tip on going to the advanced parameters. It got my pixhawk working clean. The exact advanced parameter is RC2_REV. It has to be switched from 1 to -1 to reverse the channel for pitch. That is if channel 2 is still set to pitch in the transmitter. cheers! 

I know its old post now, but Im having same issue. My Tunigy i10 does not have the reverse option in the transmitter itself when in multicopter mode, so only option is to try do it via the flight controller itself :S 

Thankyou heaps for this. It fixed my issue aswell. My transmitter does not have reverse function when in multicopter mode so this was the fix i needed. 

There were a couple of mission planner update a while back that had mysteriously reversed my pitch controls, the next update fixed their error.

Hello!

So, your copter was moving towards you in auto mode and you "reversed" the "pitch"? Actually I am having the same problems but I thought that I need to "reverse" the "roll". I have read that on different forums.

Please reply.

Thanks

Simone Chiaretta said:

I really couldn't live with the idea that I had to reverse the pitch channel to have it working correctly, so I searched around the site for something that could explain it (btw, the google search is much better than the internal search).

http://diydrones.com/forum/topics/pitch-direction-and-yaw

Basically it says that it's a bug.

I created an issue for that: http://code.google.com/p/arducopter/issues/detail?id=531

if just reverse on transmitter, does the quad will move in right direction when auto pilot?

Richard Boyhan said:

You can just reverse the pitch under radio config in Mission Planner. Whatever feels comfortable to you is correct.
Regards,
Richard

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service