Dear forum members

I am new in this place but I hope you can help me. I built an octacopter and wanted to use the new pixhawk 2 "cube" flight controller. I have the latest "mission planner" installed but there is no way to connect to the board... I always get the "no heartbeat packets received" error after the PC tries to connect with the board... I have expereince with the first pixhawk and also with a 3DR solo. I am new to the "cube" but I have "some experience" with other similar boards.

I tried everything but there is no chance to connect or to upload the firmware. The SD card is in place, The ocnnection are OK. The funny thing is that IT HAD WORKED but after some days it stopped. Could I have "fried" the board? Is there anything that I can try?

In the video you can hear the startup sounds. Is it everything normal? I did not find many info on the internet regarding the new pixhawk :-(

Views: 310

Reply to This

Replies to This Discussion

Better to post this to

OK, I did it...

Why is this not the right place?

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service