Hello friends. I have constructed the following items: DJI F450 quad frame, 4 X 960kV motors, 4 X 30A ESC, Here satellite receiver, Spektrum DX9 transmitter, AR8010T receiver, Pixhawk4 Cube flight controller. Using Mission Planner to configure the above assembly, I have successfully set all the components but can not ARM the system. Pre-flight checks are all OK. Transmitter controls are being accepted. GPS locks are OK. Up to 10 satellites are being registered. I have changed the internal safety parameters several times but can not ARM the system. Does anyone have any suggestions to overcome this problem? 

Views: 273

Reply to This

Replies to This Discussion

Just disable pre arm checks 

No, absolutely do not disable the pre-arm checks.  Look in the GCS when you try to arm, it should tell you the reason it's not arming.

Hello friends. Thanks for the replies. I will try all options, as I am getting a bit frustrated with the same result all the time. I have one more question: If I turn OFF all the preflight checks, why is it that I still get the DISARMED message on the HUD? My logic says that if there are NIL checks then the outcome should be ARMED.

yes you have a problem if you disable pre-arm checks & you try to arm the craft and it will not arm! DISARMED is normal unless you ARM the craft it should change from DISARMED to ARMED ! may be your RC radio is not set up properly ?

Hello friends. I am very pleased to advise that I have solved the problem of not being able to ARM my Pixhawh project. The solution was to install QGround Control onto another computer (#3) and run the configuration options again. To my utmost surprise the whole thing worked first time and the new configuration parameters were set into the Pixhawk. This then allowed me to successfully use the Mission Control software from the other computer. The task now is to learn how to switch controls between manual RC and autonomous via computer. Cheers. 

hello Barry,

So you didn't really SOLVE the problem. You worked around the issue. Cause of the problem is still unknown! However, it was probably because the communication parameters were incorrect...the old standby REINSTALL or REBOOT the computer is one of the most annoying suggestions the come out of a tech support reps mouth! It is one of the first things a tech at ComCast will say rather than spending time to get to the root cause of the failure...which means it will happen again to someone else.

Barry Chappel said:

Hello friends. I am very pleased to advise that I have solved the problem of not being able to ARM my Pixhawh project. The solution was to install QGround Control onto another computer (#3) and run the configuration options again. To my utmost surprise the whole thing worked first time and the new configuration parameters were set into the Pixhawk. This then allowed me to successfully use the Mission Control software from the other computer. The task now is to learn how to switch controls between manual RC and autonomous via computer. Cheers. 

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service