Pixhawk 4 will not ARM

Hello friends. I have constructed the following items: DJI F450 quad frame, 4 X 960kV motors, 4 X 30A ESC, Here satellite receiver, Spektrum DX9 transmitter, AR8010T receiver, Pixhawk4 Cube flight controller. Using Mission Planner to configure the above assembly, I have successfully set all the components but can not ARM the system. Pre-flight checks are all OK. Transmitter controls are being accepted. GPS locks are OK. Up to 10 satellites are being registered. I have changed the internal safety parameters several times but can not ARM the system. Does anyone have any suggestions to overcome this problem? 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • hello Barry,

    So you didn't really SOLVE the problem. You worked around the issue. Cause of the problem is still unknown! However, it was probably because the communication parameters were incorrect...the old standby REINSTALL or REBOOT the computer is one of the most annoying suggestions the come out of a tech support reps mouth! It is one of the first things a tech at ComCast will say rather than spending time to get to the root cause of the failure...which means it will happen again to someone else.

    Barry Chappel said:

    Hello friends. I am very pleased to advise that I have solved the problem of not being able to ARM my Pixhawh project. The solution was to install QGround Control onto another computer (#3) and run the configuration options again. To my utmost surprise the whole thing worked first time and the new configuration parameters were set into the Pixhawk. This then allowed me to successfully use the Mission Control software from the other computer. The task now is to learn how to switch controls between manual RC and autonomous via computer. Cheers. 

    Pixhawk 4 will not ARM
    Hello friends. I have constructed the following items: DJI F450 quad frame, 4 X 960kV motors, 4 X 30A ESC, Here satellite receiver, Spektrum DX9 tran…
  • Hello friends. I am very pleased to advise that I have solved the problem of not being able to ARM my Pixhawh project. The solution was to install QGround Control onto another computer (#3) and run the configuration options again. To my utmost surprise the whole thing worked first time and the new configuration parameters were set into the Pixhawk. This then allowed me to successfully use the Mission Control software from the other computer. The task now is to learn how to switch controls between manual RC and autonomous via computer. Cheers. 

  • yes you have a problem if you disable pre-arm checks & you try to arm the craft and it will not arm! DISARMED is normal unless you ARM the craft it should change from DISARMED to ARMED ! may be your RC radio is not set up properly ?

  • Hello friends. Thanks for the replies. I will try all options, as I am getting a bit frustrated with the same result all the time. I have one more question: If I turn OFF all the preflight checks, why is it that I still get the DISARMED message on the HUD? My logic says that if there are NIL checks then the outcome should be ARMED.

  • No, absolutely do not disable the pre-arm checks.  Look in the GCS when you try to arm, it should tell you the reason it's not arming.

  • Just disable pre arm checks 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Monday
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
More…