the work on my self-designed 3D printed hexacopter has been finished:) Some pics attached.

It can fly pretty well in all modes but I wanted to tune it with the Autotune functionality.

After the drone took off I switched to Althold and turned on the Autotune (Ch7). The drone tuned the PIDs for Roll for about 4 minutes and than... tried to fly away. I managed to put it to the ground by reducing throttle and disarming - it worked, uff. 

After re-arming and checking the throttle on the ground I watched a strange behaviour - the drone tried to put the throttle to full when I only touched the throttle stick on the transmitter.

Now I am wondering what happened in the air and what is wrong with the configuration causing this strange throttle behaviour. I do not want to fly the drone until that's not clear for me and the issue solved.

Can someone with more experience maye help me on this?

I attached the log file from the fatal flight. Many thanks for any hint and suggestion.

BTW. I checked the PIDs and they stayed unchanged means autotune did not write any new values.

Views: 180


Reply to This

Replies to This Discussion

it did not try to flyaway. That's a DJI & other controller  feature :)

if you plot the speed, you can see throttle demand on motor 3 max out (front left), and it's neighbour, #2 is also maxed out for a while. and yet the RPAS pitches down, and left.

Something failed, and you had not enough lift there.

you started out at 11.6 volts, so I guess you are using 3S , at the time of trouble you had only 3.55v/cell,  at lowest point only 3.39v/cell  - so a low voltage protection in ESC , or simply empty battery is not entirely ruled out.  

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service