I'm running a Pixhawk with the 10s power module from HK and can't seem to get a current reading.

I've tried multiple combinations of settings in MP and can get a reasonably accurate voltage reading but nothing at all on current for some reason.  Tried swapping cables out and no dice.  I did try flipping the pins in the parameters for config for voltage and current and got a reading then (but way off/wrong).  Also tried multiple batteries of varying size, no difference, voltage reads closely but no current reading.  I do have the option enabled for both voltage and current.

Does anyone have any ideas that I can try to track down in troubleshooting this?  things to check that I might have missed in my frustration?

Views: 1099

Reply to This

Replies to This Discussion

Update: problem found.

The good news is that the HK power  module can be hooked up backwards (input on the output side, output on the input side) and still not blow up.  The bad news is that it doesn't read current flowing through it when connected that way.

I've rectified (power e pun fully intended) and it works now.

Paul,

Did it come from HK with the incorrect XT60 connectors on the input/output?  I just tried to do a compassmot on my Tarot 960 with Pixhawk and I am not getting any amp reading.  I am thinking that I might have the same problem.  Which side are you using for the battery in?

Also, what settings are you using in MP for this sensor?

Jim

So, I just double checked mine and it turns out that I had the wrong XT60 connector soldered to my battery parallel adapter.  As a result, I was plugging my batteries into the wrong side as well...

In retrospect, yes I think my xt60 connectors were backwards because I based my new plugs on where the old ones were, not looking at the end which the 6 wire connector comes out of which is a much more reliable indicator. I'm using Pixhawk/apm power module for the settimgs. Seems to work like a charm now.

Hi Everybody,

I got this HK 10s Power module, but it seems to be not working. I´m running it on a 6S lipo and can´t get more than 4.6 volts on the regulated output, with no load on it. Shouldn´t it give 5.3 volts?


Patrick

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service