Has anyone been able to get the Pixhawk to connect to a Feiyu G3 2 axis gimbal? We are having no success here:

-9XR transmitter

-Frysky DB82 receiver

-Channel 6 assigned to tuning knob on transmitter

-Feiyu G3 gimbal control wire connected to AUX 1 out on Pixhawk

-Feiyu G3 gimbal power supply is separate

-Mission planner gimbal page set up channel 9 and channel 6 input

We get nothing, nada, no response to transmitter input. Tried many different combinations. Nothing. Gimbal just goes to extreme up position. With something as sophisticated as the Pixhawk there must be a way to do this simple thing. We just need manual control of the gimbal pitch while flying

Views: 1565

Reply to This

Replies to This Discussion

Chris,

   Is it one of the earlier models or a more recent edition? There are some differences between the boards that may be causing this issue.

    I know because I experienced similar results with one of the early original editions.

Todd H

  

It's a recent edition. Purchased April this year

On the main board is there a 3 pin connection or a 4 pin for the tilt/roll control.

I'm at work right now so I'm not sure. I believe it's a four pin but there is only two wires... A black and a white

In my experience with the 4 pin board I could not get it to work. I was having the same issue as you, it would either pitch all the way up or down, i could not control it.

I tried a multitude of combinations between the gimbal and PixHawk but to no avail.

The newer boards (3pin) work perfectly.

Todd H

Just wanted to let all readers know that I found the solution. Turns out that the order of powering up the gimbal is important. First power up Pixhawk, then power up gimbal. Do not power everything up simultaneously. I am still trying to improve the predictability of the adjustment knob. The gimbal will swing from full down to full up without problems. You can even get it to stop where you want it at level. The problem is this: When flying you cannot see which way the gimbal is pointed. I need a way to ensure the gimbal is pointing straight after moving it. Perhaps a solution is to limit the upward tilt to a maximum of level. This way after moving gimbal in flight, you can move the knob to the upper limit and be assured the camera is facing forward. I have experimented with max angle limits in mission planner to no avail yet

Good to hear Chris thanks for the update.

Sounds like you need to set the servo limits. This will give the min and max for pitch control.  

Servo Limits hold the minimum and maximum PWM while Angle Limits are the earth-frame angles (in degrees) that the gimbal can achieve i.e.0 degrees is straight ahead -90 degrees is straight down.

Set the servo limits and the pitch will only go to those numerical values.

Todd H.

I wish that worked. Seems no matter what max angle values or pwm limits I input in the gimbal screen makes no difference. Just get either full travel or no travel 

Hi,

I just installed the pixhawk in the XuGong and have exactly the same issue.

No tilt control (tilt channel connected to pixhawk) when I power the quad up. If I unplug the gimbal power and plug it back in after that I get all the control immediately.

Means the Pixhawk would need to be powered first and after that the Gimbal.

Has anyone found a workaround (setting on Pixhawk or gimbal/FW) that solves this?

Thanks a lot,
Eric

Can you tell us, if you solved your problem?

If not, what voltage on your separate power supply is apply to your gimbal?

thank you

Can you give more detals about how your power supply the gimbal ? 

And how your 3 wires connectors are connected?

Thank you

Yes problem is solved. You must power up gimbal after powering up Pixhawk. There is not a separate power supply. Power comes via 3dr power module straight off the 4s battery

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service