Hi,

I am having undiagnosed problems with three of my Pixhawk autopilots, each on a different aerial platform (Aero-M, X8 wing and AgEagle).  Simply put, as soon as I switch from any of the manual modes to Auto to begin my survey grids the Pixhawk shuts off the throttle to the motors.  I tried re-uploading the original settings for each UAV, but to no effect.  I checked for the correct mode showing in the HUD in Mission Planner and they always show the correct flight mode (e.g. Auto).

Has this happened to anyone else?  What are some of the likely causes of the throttle being cut by Pixhawk when switched to Auto mode?

Thanks for your help.

Jan

Views: 300

Reply to This

Replies to This Discussion

Please post .BIN log, that is, unless you prefer wild guessing :)   

Sorry, should have done that in the first place. :)  BIN log and the UAV's parameters used attached...

I should add that I have since recalibrated the accelerometers, GPS and set the min/max values on the RC transmitter.  Basically, I've gone through the initial setup steps.

Attachments:

1: if you have problems, and are not a developer, try current release version, instead of 3.3.0beta1 

2: disable stall prevention, if has the ability to override throttle, and requires you to set up TECS properly 

RE 1:  Are you referring to my Pixhawk firmware version?  

Thanks,

Jan

Yes

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service