A few users, myself included, appear to be having issues calibrating accels and/or arming when using APM 3.2 on a Pixhawk.  I see posts here and there, but thought it may be best if those having the issue could all 'check in' to one post so that the developers can see how widespread the issue is and gather data.

My Pixhawk will arm occasionally, and will even fly successfully.  Occasionally however it will not arm and I will receive the pre-arm error "Accels not healthy".  A few days ago I was able to arm and fly thorugh one lipo, then after landing and swapping batteries I could not arm due to this reason.  I have attached the logs from the successful flight, as well as the failed pre-arm logs, to this post.

As you can see from these images there is something amiss with IMU2.  This is a snippit from the good flight, showing values for AccX on IMU1 and IMU2:

and here are the same values on the second attempt, pre-arm.

In the 3.2 release thread a few users had mentioned the issue and Randy advised to set the log_bitmask to "131070" so that it will log everything including the pre-arm checks.  I encourage others having the issue to do the same and share the logs and experiences here so that we can find out what is going on here - is there a bad batch of Pixhawks in the wild that only now show the hardware errors due to something new in 3.2, or is there an issue in the APM software?

Views: 53604

Attachments:

Reply to This

Replies to This Discussion

Denny,

Let's try and keep this thread focused on the accelerometer failures.  Could you report this separate issue in the APM Forum?  Including a log showing the problem would also be great.  Perhaps two dataflash logs, from two consecutive bots that show the failure.  Remember if it's happening before arming to set the LOG_BITMASK to log while disarmed.

"DJI works everytime", that's funny!  If you're using DJI as your benchmark you have your standards set pretty low.  I challenge you to contact DJI support and actually get a reply!  But back to the subject of this thread, 3DR has identified a Pixhawk hardware issue caused by stress testing proceedures.  They have corrected the manufacturing proceedure and they are actively working through it.  They have identified the manufacturing dates from July 2014 to Jan 2015 as being possibly effected.  The symptoms started showing up with the release of 3.2 firmware which does an accel prearm comparison between the two accel chips that was not performed in earlier firmware releases.  They have released firmware 3.2.1 which now attempts to resolve the problem.  3DR has stated they will replace your Pixhawk manufactured between these dates if you can provide evidence in the form of a log file showing you have the accel problem.  You clowns need to read the entire thread from the beginning and if you suspect you have this issue stop whining and CONTACT 3DR SUPPORT!

In the mean time..... for people with LSD303d failure ie IMU2 (wont work with mpu6k issue).

When experiencing the failure i.e. "bad_acc_health"  try unplugging the battery and shortening PM battery input pins for 5-10 secs. Worked every-time for the last 30-40 times, make sure you unplug ALL your batteries from your system beforehand.  

Rob,

First, I fly fixed wing but am commenting and seeking help in a copter thread. There may be differences by virtue of the FW.

That said, my specific experience wrt "bad accel health" does not lead me to conclude there is a solder joint fracture. Why? Typically poor solder joint integrity usually manifests itself either as open or intermittent. If intermittent, vibration and/or thermal excursion will reliably reproduce the failure signature. In my case plugging and unplugging the battery randomly produces the bad accel health warning. Granted, powering up the board could produce sufficient heat to close the solder joint enough to conduct again but doing this 10 to 12 times results in hits and misses of the bad accel warning.

In essence, it's entirely plausible that a solder joint failure was causing some of the anomalies but for me, I don't think it explains all of them. Sometimes there are two failures causes occurring simultaneously. The smoking gun may have had blanks.

As for my logs, I erased and started fresh on both my Pixhawks. I erased everything! Installed a Copter FW and then erased again and installed Plane FW. I now have two flights on one of the Hawks with no warnings. It's on the SAME plane, SAME environment, GPS sats and HDOP were very close as well. I also examined the solder joints on the IMUs at 20X and can see no evidence of a bad solder joint. (could still be a micro-fracture) Btw, I also GENTLY flexed and twisted the Hawks in their housings without creating a bad accel warning.

I did review logs with warnings and those without. On the ones with warnings, the signatures looked like Trdge's case study. BUT the ones without warnings looked fine and would have passed scrutiny. So, if one has a "good" log, it doesn't mean they necessarily don't have the issue.

If I get more anomalies, I will certainly post, in hopes of getting some assistance. In the mean time, it would be really helpful to a lot of us if someone could make a tutorial or YouTube on reading logs for the most frequently encountered issues.

Thanks!

Just curious, what led you to this approach?

Multiple things.... but the final tip was googling "issues with lsm303d" first hit is pololu community forum thread. Apparently lsm303d is very sensitive to how it needs to be powered down: if voltage goes to 0 right away all is good, but if it falls at a certain rate lsm303d gets stuck on a single value until voltage drops to 0. Also the new 2.4.6 version of the ****hawks with "original NEC tantalum  capacitor" to stabilize sensors. I figured out that the issue was with the power, originally I though of bad filtering so I put an LC filter on one of the machines and that "cured" my issue as well, now I understand why - the additional capacitors were changing the way power was dropping. 

P.S. someone of pololu staff mentioned adding a 1k-10k resistor across LSM303D vdd to guarantee instantaneous voltage drop, but I haven't tried that myslef as I am not sure what will be the result of adding a resistor between 5v and ground on the pixhawk, if someone knows its safe/unsafe let me know.

Richard KennedyMost people including myself have had a really good experience with 3dr customer service. Did you actually call them or just assume your out of luck because it's past 90 days?

The CS wrote sth. like this.: "Yes, The warranty is 90 days and the only and last thing you could do to fix it would be downloading Q GROUND CONTROL and choose Pixhawk4 if this doesn´t not work would just be to buy one."

Sorry for this, but it is related, since some user with IMU errors should keep an eye onto those 90 days.

European custumers like me usually don´t realize this short time period being important.

I recommended my friends to buy genuine 3DR @ that time, and did not know, that there is a big disadvantage, buying this directly from 3DR US.

Very nice find!
Looking forward to trying this in the field.
I have some extra capacity in the lines to the ESCs so that fits in quite well.
Did you actually measure the rate the voltage drops when battery is disconnected.

nope, my only instrument is a multimeter which I do not think is sensitive enough. 

This is a fantastic find!! It explains my issues much better than the "micro-fractured" solder joints. This is along the lines that I suggested in an earlier post. Great detective work.

Since "shorting" the Vcc connection (without power) before every flight is a PITA, a RC fix would certainly be best.

Thanks!!

If this works for me, i'll just use a spare battery connector and connect the poles. Just plug it in before fligt and voila. Not too difficult...

go ahead try, just make sure that you are experiencing the IMU2 failure i.e LSD303d, as far as I understand MPU6k issue should not be resolved this way. 

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service