A few users, myself included, appear to be having issues calibrating accels and/or arming when using APM 3.2 on a Pixhawk.  I see posts here and there, but thought it may be best if those having the issue could all 'check in' to one post so that the developers can see how widespread the issue is and gather data.

My Pixhawk will arm occasionally, and will even fly successfully.  Occasionally however it will not arm and I will receive the pre-arm error "Accels not healthy".  A few days ago I was able to arm and fly thorugh one lipo, then after landing and swapping batteries I could not arm due to this reason.  I have attached the logs from the successful flight, as well as the failed pre-arm logs, to this post.

As you can see from these images there is something amiss with IMU2.  This is a snippit from the good flight, showing values for AccX on IMU1 and IMU2:

and here are the same values on the second attempt, pre-arm.

In the 3.2 release thread a few users had mentioned the issue and Randy advised to set the log_bitmask to "131070" so that it will log everything including the pre-arm checks.  I encourage others having the issue to do the same and share the logs and experiences here so that we can find out what is going on here - is there a bad batch of Pixhawks in the wild that only now show the hardware errors due to something new in 3.2, or is there an issue in the APM software?

Views: 53611

Attachments:

Reply to This

Replies to This Discussion

Artem,

I just cycled my copter (3.2.1 having IMU2 failures at least every other boot) 10 times using your method and not one "bad accel health" warning! Thanks!!! 

Quite awesome. Good stuff!

I have a few spare XT connectors laying around. Maybe solder up one with a short, see if it works. We'll see!

It works! Thanks

This weekend I finished building my new Quad. I have used a brand new 3DR Pixhawk (not a clone).
I get following messages : Accells inconsistent og just Bad Gyro Health.
Tried to load previous firmware V 3.1.5 and later again V 3.2.1 with the same result.
After I reloaded V3.2.1 I was able to make one succesfull calibration of the accellerometer. But shortly after I got the sad message again.

How long ago did you buy the Pixhawk and from who?  If it was old stock from a dealer and manufactured between July 2014 and January 2015 it could be one with the known accel problem.  My Pixhawk was manufactured in Oct 2014 and I got those same messages.  3DR replaced my Pixhawk under warranty and those messages are now gone.  I know you can read the mfg date from the log files.

Did you try the method suggested above? That is, shorting the PM input to bleed off any charges which seem to affect IMU2. It has worked for a lot of people.
Thank you very much for the information :)
I bought it at the 3DROBOTICS a month ago and it just came out of the box this weekend.
Thanks for the suggestion. I will see if it is posible to shorten the PM input a bit more.

Please do not "shorten" your PM input. Steven was telling you to SHORT your PM connector (touch the negative and positive together with something metal). Make sure that no batteries are connected to your system when you do this. 

Kim, if you have a log file that looks like one of these:
http://uav.tridgell.net/MPU6000-error/summary/summary.html
please contact help@3drobotics.com for a replacement

Well, thanks for letting us know. I really expected that it will be something with power because it went away when I take off bluetooth module from copter. I can imagine that this will simply change way how is voltage getting off.

Can you give us your LC circuit schematic ?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service