A few users, myself included, appear to be having issues calibrating accels and/or arming when using APM 3.2 on a Pixhawk.  I see posts here and there, but thought it may be best if those having the issue could all 'check in' to one post so that the developers can see how widespread the issue is and gather data.

My Pixhawk will arm occasionally, and will even fly successfully.  Occasionally however it will not arm and I will receive the pre-arm error "Accels not healthy".  A few days ago I was able to arm and fly thorugh one lipo, then after landing and swapping batteries I could not arm due to this reason.  I have attached the logs from the successful flight, as well as the failed pre-arm logs, to this post.

As you can see from these images there is something amiss with IMU2.  This is a snippit from the good flight, showing values for AccX on IMU1 and IMU2:

and here are the same values on the second attempt, pre-arm.

In the 3.2 release thread a few users had mentioned the issue and Randy advised to set the log_bitmask to "131070" so that it will log everything including the pre-arm checks.  I encourage others having the issue to do the same and share the logs and experiences here so that we can find out what is going on here - is there a bad batch of Pixhawks in the wild that only now show the hardware errors due to something new in 3.2, or is there an issue in the APM software?

Views: 53826


Reply to This

Replies to This Discussion

I had one occurrence of not being able to arm on the filed. MissionPlanner reported "Access not healthy".
The logs shows normal values for IMU1 and constant values for IMU2 of AccX=60.39, AccY=56,18, AccZ=56,80.

This stayed the same upon disconnecting and reconnecting the battery.

Trying to do accel calibration on the field failed, as reported by MssionPlanner ("calibration failed") and APMPlanner (values all "NaN")

I don´t know if it is related, but I noticed that in the cold temperatures here in Germany the Accels drift apart quite a lot on temperature changes. Auto log-analysis gave me an IMU mismatch warning (0.71) and a fail (2.1) ...

In the attached Better.BIN you can see the drift quite clearly if you compare des AccX,Y,Z-values before the start and after landing.


Do you have the log that shows the constant values on IMU2?  That sounds exactly like what I am experiencing.

It´s in the "Bad.BIN" I posted above.

I had assumed it would be in "Bad.BIN" but when I view the graphs for that log I see decent accel values

You are totally right.
Too many logs on my desk. Sorry, I obviously confused them.

34.BIN is a faulty one...


WOW that looks very similar to my issue. I'm wondering if temperature change really is the issue.  I'm in the US on the east coast (WV to be exact) and it's rather chilly outside this time of year.

Still, I've seen similar behavior in my office, but not as often... Really wish I knew for sure before I send this unit back for replacement tomorrow - I'd hate to waste time shipping if the other unit will experience the same behavior.

I was speculating that one of my accelerometers soldering points is disconnected form the board by the temperature change. And once the whole FC is cooled down it reconnects. i.e. bad soldering.
There is one other guy here in Germany having the same issue.
And after some minutes outside it just goes away.

Would be interesting what happens if someone just took one of a board for testing ;)

That's definitely a possibility - but did you have this problem prior to 3.2?

I guess something we should test is going back to 3.1.5 and testing in the same conditions, and then comparing the logs to see if IMU2 is exhibiting the same behavior.

I'll try it this evening if I get the time.

I've seen that today. Can't calibrate it, tried outdoors 3 times. A little chilly.

Also same issue, some flights are perfect, and some I can't get off the ground. I need to manually disable all pre-arm to get it in the air. During flight, it's fine.

@thatJoshGuy, I'm still having the same problem as you (can not calibrate Accel using AC3.2).  Logs say I have mismatched IMU, but I do not have any Idea as how to fix it.  As a result I have gone back to AC3.1.5 where I have no problem......Copter flies fine!

Could you post a log.

I tried to find logs from when I was still on 3.1.5. but i deleted most of them and the ones I have aren´t faulty.

ive seen bad accels on 3.2 bench testing a Virtual Robotix ubrain, it went away. Not sure why, but I wonder if its 3.2 specific rather than pixhawk.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service