After many perfect tests of my PixHawk quad running v3.1.2, in Loiter, AltHold, Auto, RTL and Guided modes, I decided to try my radio failsafe. Everything had performed flawlessly up to this point - perfectly, and with zero surprises. 

I was in Guided mode when I switched off my radio.

With the radio off, my ground station (Droid Planner 2) announced the quad was doing an RTL, and it did - right back to the correct spot. After it hovered over my home location for a second or two and then decided to take off in a random direction in a straight line, holding altitude steady, not flying crazily. Like it had decided to go to a new Guided point.

I switched my radio back on, toggled my modes back to Stabilize, and regained control safely.

Here's a shot of that from the generated KML for the RTL part. Visually this lines up with what I saw in the field. The quad came from the top right where it was loitering in Guided to the bottom of the "V" (my home location), stayed for a moment, and then went off to the top-left:

The odd thing here is that the RTL did return to home, and I see no evidence of any other waypoints being issued or modes being changed.

The graph of "wp_dist" goes down until it hits my home location - and never goes back up - while my "dist_home" goes down until it gets home, and then rises as the quad goes away again:

The dataflash doesn't seem to provide anything useful in this case, but I've attached both it and my TLOG file to this post. Another RTL in the same file worked without a hitch, and I've done several RTLs with this setup in the past week as I've been testing the system.

I've really tried to understand this myself, and I've had other eyes on it - but the best we can come up with is that it was a bug. The logs contain a good record of what happened - and aside from the wp_dist not increasing as it flew away, I can't find anything in the file to suggest obvious reasons for this behavior.

Any help would really be appreciated. Thanks!

Views: 1757


Reply to This

Replies to This Discussion

Can anyone take a look and tell me if this was indeed a bug, or a misconfiguration on my part?

The aircraft has been performing perfectly aside from this one RTL, and given that it's a potential failsafe problem, I think someone in the dev group should at least take a glance at it.



I had exactly the same thing happen a couple of days ago.  I've new to this UAV thing and have been building and crashing my way to a flying machine over the past few weeks, using a pixhawk on f450 frame.  I've got to the point now where I'm successfully hovering, loitering, flying in simple stabilise mode (my brain just can't cope with non-simple mode yet), RTL and even some auto missions.  Once I sorted my balance and calibration issues my crashes greatly reduced and the quad is absolutely rock solid in hover/loiter and auto mode.

I went to try throttle/radio failsafe.  I turned off the radio (Taranis->X8R) and the quad immediately went into RTL as expected. It came back to the takeoff spot, hovered, then flew off in another direction.  As with Troy, it seemed calm and in control and at a stable altitude, just decided it on it's own!  Being new to all this I dealt with it in a calm and collected manner by panicking and turning the radio on and mashing buttons at random, fortunately causing it to crash with nothing more than a broken prop (4th one that day..).

This was either 3.1.3-rc or 3.1.3, can't remember which. I've since checked the settings (no-pulse on the taranis) and they all seem OK for failsafe, as far as my novice eyes can see.  GPS looks OK during the event.  Flashlog attached.  It would be really great for someone in the know to have a look at this as I'm kind of scared to fly until I have some confidence in the failsafe.


I didn't know you could graph the path in kml, really cool.  Mine looks suspiciously similar - it comes from the top, hovers at the bottom point where it took off, then decides on it's own to fly off to the top left


Thanks for taking the time to respond. I've flown lots and lots since, without issue - but I haven't had the nerve to try my radio failsafe again.

Perhaps someone from the developer group can take a look?

For now I'll take a look at your bin log and see if there's any relation. 

Thanks again!

Looks like someone else might have the same problem:

I summoned the courage to try this again yesterday (switching off my tx) and it happened again, twice.  GPS was fine - loiter and auto working fine.  Looks like either a major bug, or else major setup problem (which I won't discount!).  Is this a known issue?  Running firmware 3.1.3 on pixhawk.

Open a failure thread

Apologies, how do I do that?

I have added my two cents to the following failure thread which seems to describe the same problem:

It references this thread, and it has more developer activity.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service