I believe I have a problem with my Pixhawk and was hoping for some help.  Also posted this on rcgroups.

The issue is that when my speed controllers are hooked up to the Pixhawk they exhibit a bad sync issue.  However when they are connected to my old APM (3.1) or just a receiver directly they do not exhibit these symptoms.  This has resulted in 4 crashes now until I just tonight narrowed down the issue to the Pixhawk.

Can anyone advise what is going on?  Here are the specs of my setup:

Afro 30A ESC's with SimonK firmware (have tried all versions, and made my own with various parameters)

Tiger MT2216-9 1100kv motors

4S 3700mah battery

https://www.youtube.com/watch?v=i7_gVoY8q8M

https://www.youtube.com/watch?v=VTK81IANyUE

Views: 46160

Reply to This

Replies to This Discussion

I'm no expert but as I understand it blheli settings are more dependent on the motor/prop rather than the flight controller.  So settings can be very different depending on which motor you have.  However, pretty much all desync issues i've heard of are on low-kv motors.  You've got relatively high-kv motors so desync shouldn't, theoretically, be a problem, as far as I know.

BTW I ran 920kv (DJI E300) motors with afro 20a slims ESCs with blheli for many flights with zero problems using standard default settings.

hello,

to be onset I have not needed to messed with the settings in BL Heli firmware I suspect this is where your going wrong. the simonK is not going to produce any better results. here is my original post on BL heli users have posted settings as well

http://diydrones.com/profiles/blog/show?id=705844%3ABlogPost%3A1457...

also if you looking for examples BL-Heli settings you can can find some here 

http://www.olliw.eu/2012/owsilprog-tutorials/?en

any issues from here on caused by the arming button disable it!

Hello Guys,

are you still using the arming button and having issues with bl-heli!!!!!

suggest disable the arming button when Pix Hawk is your FC

Thanks ever so much OG... Much appreciated... Cheers and Safe Flying!

Hi,

I just wanted to add my voice to the list of people who've experienced multiple crashes when running Pixhawk with Afro ESCs running Simonk (sorry, not sure which version specifically - whatever they were shipped with mid 2014).

I've got multiple Pixhawk's and a bunch of Sunnysky 2212 980kv v2 motors driven with Afro Slim 20A. I've successfully used the same motor/esc combo on APM 2.6, Naze 32 running baseflight and cleanflight with success. But the Pixhawk + Afro ESC combo I've seen sudden de-sync and had the quadcopter fall out of the air on numerous occasions - three broken frames.... The latest on Sunday with a DJI 450 frame, after a manual tuning session I engaged auto tune to see what 3.3.1 would produce but during yaw tuning one motor de-sync'd and it fell 5 meters out of the air. I'd previously not figured out what was causing it, but after doing a bit of searching and finding that it's a common well documented issue over the last year, I'm just dumbfounded that the root cause isn't isolated yet, or maybe I didn't find the right post yet...  

For now, I've flashed BLHeli and will do some bench testing...  fingers crossed.

lol, just upgrade them already, running afro slims with 2216 800ies since January I've flashed them with blheli for easy of maintenance. 

same issue here with Hobbywing Quattro 4-in-1 ESC, just don't run AutoTune on that config and you'll stay in the air.

Hi Artem, for easy maintenance we now have an APP pn Google for setting up properly and flashing SimonK. Here is the Link: https://chrome.google.com/webstore/detail/rapidflash/gehadojofkekob...

I have not used it yet, but can't wait! I still had a flip again last WE changing from Baro back to Stabilize mode with Pixhawk after 10 minutes in the air! Harrrr. I rebuild it 2 times already changing all ESCs and Motors re-soldering the power distribution, twisting the signal cables etc... I will use your recommendations of using PWM_Com ON and high timing on the motors, as it seems this would help from your previous recommendations...

Cheers, I trust most if you Guys will find this App useful for setting up your Simonk Firmware before flashing your ESCs. Enjoy and Safe Flying!

...WTF? I still haven't heard back regarding my issue. I understand being busy as I am also a business, but if I can't get tech support then I have wasted my money...

Whats so hard about a simple reply if you know the answer?

Q: Why do I get a busy signal from all for of my Emax Simon Series 12A ESCs?

APM 2.6

Emax 12A SS

Emax MT2204 ll

Gemfan 6 in props

Can anyone please advise? Or should I simply scrap the APM/Pixhawk product for Naza?

Pixhawk 2.1 has a solder option to provide 5V PWM

The reality of this issue is that 95% of the time, it's due to bad wiring... but in the other 5% we have a solution for you.

Hint... the green Solo cube comes with this mod :)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service