Hi everyone

Last day I was performing an auto mission when Pixhawk changed suddenly from AUTO mode to ALT HOLD. No, I didn´t give any input to that and there was no failsafe activated to blame.

Only thing I see at the log is RC error messages, but in auto mission this shouldnt be any problem.

MAVlink communication between Pixhawk and a Raspberry was on use during the flight, don´t know if it can be related.

Any help could be appreciated. I leave here bin file.

Thanks in advance!

2018-06-22 13-47-15.bin

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • The screenshots are from APMPlanner2 ,  the best GCS for log analysis, especial when you learn the power of presets and graph groups..

    you can see if there is a better firmware, and/or a changelog that indicate they fixed an issue with incomplete dataframes being output. 

     

  • It is a FrSky X6R receiver for a Taranis X9E emitter. Lot of problems in late times, loses RC connection at a very close distance.

    What program do you use to analyse the logs? I use the own Mission Planner, but don´t look as clear as this one you do.

    Andre K. said:

    many of your channels, including RC1, remain at "failsafe value"  of 874, it's a if your receiver partialy recovered, but did not got them all.

    I would throw it away, what brand is is ?

    3702434444?profile=original

    Pixhawk changed flight mode from AUTO to ALT HOLD during flight
    Hi everyone Last day I was performing an auto mission when Pixhawk changed suddenly from AUTO mode to ALT HOLD. No, I didn´t give any input to that a…
  • Ok I see it now, thank you very much. I still don´t know why at second 47 RCIN3 signal recovered but RCIN5 no, but it is an advance.

    What program do you use to analyse the logs? I use the own Mission Planner, but don´t look as clear as this one you do.

    Thanks!

  • many of your channels, including RC1, remain at "failsafe value"  of 874, it's a if your receiver partialy recovered, but did not got them all.

    I would throw it away, what brand is is ?

    3702434444?profile=original

  • Late reply because I am on vacation.

    When you lost RC signal, RCIN.C5 was AUTO mode , PWM 1545us 

    3702434468?profile=original

    When RC were recovered for a while (see RCIN).C3  , then your mode switch were suddenly still at 874us (ALT.HOLD)  , as if there were still no signal..

    3702434427?profile=original

  • Dear Andre K

    Thanks for your answer, but I am not talking about that change. I am talking about the change in second 47 from AUTO to ALT HOLD, wihtout any RC input as you can see in this capture:

    3702434053?profile=original

    Captura.JPG

  • Seeing you log, you were in RTL mode (commanded by RC) , then switched to ALTHOLD (by RC)

    PWM in on RC5 verifies it:

    3702432990?profile=original

    your description does not match the log...

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…