There is a known incompatibility issue with Pixhawk FCs and DJI Tuned Propulsion Systems. And I have seen various solutions online in multiple forums, including this one. Problem is, some of those solutions are months and even years old and the info is incomplete. All I'm looking for right now is consensus on how to resolve this known issue. Here's some background on the subject.

I have two UAV's built on Flywheel 450 DIY clone kits, each with a Pixhawk PX4 running 1.4.1dev. Both fly fine with the cheap clone kit parts, but they are not very resilient. I have had multiple motor failures while in the air. I understand that's what you get when you buy cheap parts. So in an effort to upgrade I got a DJI E310 Tuned Propulsion System from the brick and mortar Multicopter Warehouse shop in Castle Rock Colorado (they are investigating this issue for me, as well).

The core of the issue is that the 420S ESC that come in the E310 kit are already "tuned", so you are supposed to skip that step, as stated here;

So, I did indeed skip that part, and my UAV now flips when given enough throttle for take off. I triple checked, everything is spinning properly, motors and props.

Obviously the ECS need some sort of calibration, or the throttles have to have their PWM values manually set. I'm really not sure.

Now in investigating the issue online I see that there are a lot of people experiencing the same issue and they have come up with the flowing solutions.

  1. Stop using a Pixhawk and get a DJI Naza-M and be done with it. 
    • That solves the immediate issue of getting the UAV up in the air, but it doesn't take into account all my proprietary custom accessories that run off the Pixhawk. I have to be flying on a Pixhawk.
  2. Flash those 420s ESCs with firmware that works
    • I have seen a couple of posting where they claimed this works. but when going to the link the link is missing, 404. What firmware is working, where do I find it and how do I flash it?
  3. Just get new ECSs with known compatible firmware.
    • Sure, but I hard soldered in those ESC to the PDB and all that hard work, time and money will be lost... which is frustrating. There's has to be a simpler, less frustrating, solution. 
  4. Manually set your throttle PWM values to 1000min and 2000max.
    • I have seen this mentioned but I haven't seen anybody confirm that this solved their issue.

Is anybody familiar with this issue and know of a solid fix, something I haven't herd of, or one of the ones listed above?

Any practical insight will be helpful.

Views: 5342

Reply to This

Replies to This Discussion

Hi, MOT PWM MIN should be 1120

Hi Troy,

 have a DJI E600 system with Pixhawk. I am having the same issue as Kimberley (July 31 post) - constant beep from the ESCs. So just to recap I have to set RC3_MIN to 1120 and MOT_PWM to 0?


Troy Gamm said:

Ok, well it seems that there is an answer for this issue. A sharp guy (Patrick Wells) on the FB group for the Pixhawk 2.1 suggested setting the RC3_MIN to 1120. I was skeptical since I had already tried setting MOT_PWM_MIN to 1120 with no success. You do have to set MOT_PWM_MIN to 0 so it picks up the RC3_MIN Parameter.

With RC3_MIN set to 1120, one of the motors constantly spun even when not armed so I backed it down to 1100. No more tipping or flipping on takeoff. Just a smooth ascent no matter how slow I was on the throttle. This was the first time since I built this drone that I didn't have to use pitch and roll controls to keep it from tipping over on takeoff. not sure why this works but glad it does. I am still going to keep the 40a ESCs I purchased for when I build a larger drone.

Please let me know if you have any questions.

HI There,

I'm new to the forum and to the RC world also, but since I've recently struggled with my DJI ESCs (at least that was what I thought...) that came with the DJI F450 flamewheel set, I decided to post where went wrong. Basically my quad kept flipping as soon as I gave a little bit of power.

I've read in several forums, that the most common case for this extreme behavior was related to the motor order. So I checked like 4 or 5 times.... just to make sure I wasn't getting it wrong... it happens that, I did check it, but following the WRONG INSTRUCTIONS!

Basically, I've followed through the DJI building instructions coming with the set that specified the motor order is as follows:

  • Counter clock-wise starting from the front-right motor is 1-2-3-4

The only problem is that if we're connecting it to a Pixhawk the motor order is 1-3-2-4... so yeah... that was it! Stupid mistake...

In the end... it had nothing to do with the calibration (although I did set MOT_PWM_MIN and MAX values to get the props to spin synchronized as soon as it is armed).




Hi.  I'm new here, building an F550 using Pixhawk mini and DJI E310 power.  When I power up the system without props I get very inconsistent motor performance.  Sometimes they spin up proportionally to the throttle stick. Sometimes all the motors are in synch, sometimes one or two don't start until almost full throttle.  When I ask QGroundcontrol to start a mission, all motors immediately go to full throttle and there is no response from the throttle stick.  I can't kill it, but after several tries to disarm it slowly stops.

I'm totally confused by all this inconsistent behavior.  Some of the replies above lead me to think the motor sequence on the Pixhawk is not 1-2-3-4-5-6 but maybe something else.  I also think something else is not set up right but I don't know where to start debugging.  Looking for the experts in here to lend a hand to this novice.  Thanks. Joe

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service