Hi. Had a flyaway today. My heavy hexa (11kg) with Pixhawk ArduCopter 3.3.3 crashed into a tree after something failed in RTL sequence.

After analyzing all info in both dataflash and tlogs, I can not find anything wrong. RC Connection was lost and the drone went into RTL, came to the home point, hovered for several seconds and then went away and down until a tree caught it. I checked GPS, compass, and suggested info in manuals on the APM website.

Maybe more experienced pilots can find a problem in my logs. Please advise.

Thank you!

Roman

Views: 649

Attachments:

Reply to This

Replies to This Discussion

Roman,

there seems to be an issue with your 2nd mag - especially z. I suggest to calibrate it again and run a CompassMot. 

Vibrations could be better, but (theoretically) should not cause a problem.

I am not an EKF expert but the Gyro bias looks strange as well.

Best regards,

Thorsten

While reading all parameters list I found an interesting one: LAND_REPOSITION. This value allows to reposition the drone while landing and that's when my flyaway happened.

As Randy said in the past: "By the way, the bug we found in AC3.1.4 (the current official release) is that the user's roll, pitch and yaw inputs are not ignored while landing after a radio failsafe (aka throttle failsafe).  Some transmitters send crazy roll and pitch inputs during a radio failsafe so this can lead to the vehicle speeding off as it descends."

I guess, they added this parameter to solve that problem. I checked my system and the parameter was set to Enabled, so my RC, I guess, was sending some commands which repositioned the drone into a tree :)

Maybe there is a trace of that in the logs...

I will recalibrate and run the CompassMot.

Don't know about Gyro bias, but will check it.

Thanks,

Roman

This is my Elevator channel which shows my inputs while landing. So, my actions crashed the drone, I guess.

nah I dont think so , i dont think thats right...during RTL the stick inputs are ignored, only on the landing phase will they work again.....I think you had a mechanial problem of some sort because if you keep looking towards the end (where I circled in greed) your stick inputs are level yet your copter is pitching and rolling all over the place, and not matching the desired pitch/roll requested by the controller....so you either hit something or you have a motor/esc problems of some sort....

Attachments:

Thanks for the analisys.

After the crash, drone received almost no damage. Even my T-Motor 18" props are all ok. I checked everything and all is in good condition and ESCs and motors work well. I even checked motor esc pairs for sync issues.

Before the RTL, it behaved strangely in Loiter. It held its poition poorly. I was searching for bad GPS or compass errors but cannot find anything. It flew great in Stabilize.

I will calibrate everything again and run the compassmote. Then will testfly again. I hoped to find the issue from the logs. Otherwise my heart will stop if it will crash again.

After analyzing telemetry log for many hours I think that my elevator input caused the crash. Please see this pics, on time mark 11 drone started landing procedure. Elevator shows that stick was at max, and Nav_Pitch shows drone rising its nose. So if I had my Elevator maxed, it had no effect while RTL, but as soon as landing started, it caused nose up and movement towards a tree.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service