I'm building a hexacopter with a Tarot T960 frame and a Pixhawk.  Here are my other components:

HobbyKing 40A BlueSeries Brushless Speed Controllers

iPower MT4114 320kv

17x55 props

6s Lipo

I've built the thing and gone through ESC calibration without issue.  I can also get it to arm just fine.

However when I go to fly.  I arm it and it the motors spin up just fine.  However, when I bring the throttle up even to the max the model does not get off the ground.  I know the motors are capable of spinning faster because I can give it more on the other sticks (pitch, etc) and it will start to lift off on one side (I already damaged a prop doing this).  I also have verified that the props are all spinning the right direction.

It is probably a simple problem, but I can not find how to get it to give the machine more throttle to get it off the ground.  Any ideas?  Thanks in advance

Views: 3070

Reply to This

Replies to This Discussion

I ran into this problem about 2 weeks ago on my APM 2.6 build. Check your THR_MAX parameter. It is supposed to be in percent * 10. Mine was set at 80 even after a firmware reload...meaning 8% was the max throttle it would attain. I set it to 1000 (100%) and all is well.

Thanks for posting this.  That was the problem.

Glad I could help. That problem drove me nuts until I finally figured it out one day while scrolling through the full params list in MP.

I have similar problem. I cant get full trhottle out and I have calibrated ESC and checked THR_MAX to be 1000. Here is the logg stream during test.

On a previous log fra a real flight, I can see similar behavior; thr out is below thr in even during full throttle short time acceleration test in stabilized mode.

I too had this problem, this time on a pixhawk. Maybe its an issue with the firmware release? and also I'm using a clone (can't afford the real one :/ ) and am interested to know if you guys are using clones or the real thing?

Im using real Pixhawk from 3DR

Can MOT_TCRV_MAXPCT be relevant??? mine is set to 93 for unknown reason. But that is outside range (20-80) according to http://copter.ardupilot.com/wiki/arducopter-parameters/#Thrust_Curv.... Anyway, the value give a kind of sense because on the log, I can see that the maxs output throttle is about 93% of input throttle.

Hi Guys!

My Setup is: All From Aliexpress.

Alien H4 600 size Quadcopter

40xx Motors - 14'' Prop

80A esc

Turnigy 9x with PPM encoder

4s Batt

Pixhawk ( Not Original )

I had the same issue, and trust me i left it as it is for a whole year, i got really frustrated, until tonight when i took out everything and started re-calibrating everything from start.. I did everything required to operate my PIXHAWK, and it started working got GPS fix and all,


Got the same issue of Throttle not increasing, Where as the Pitch/Yaw/Roll All responding at high speed..

I tried THR_MAX parameter and set it to 1000 - 100% but that didnt solved..

I tried ESC calibration but that didnt solve either..

Then I tried Changing the firmware, I tried several previous version none of them loaded.. But my Issue did solved by ONE firmware that was one version older than the current version it was in the PICK PREVIOUS FIRMWARE DROP DOWN.. I chose the top one.. or i dont know if it was the latest one hehehe!!!

AND now i am so happy after an year that my Quad is working perfect....  

Mine solved by changing firmware.. I think other guys should also do the same.. see if it works...

Thank you 


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service