Pixhawk loiter wobble problem!

Hey first of all i'm new in this forum and i'm sorry for my bad english :P 

I bougt a pixhawk controller for about 5 month ago, before that i have been struggling around with a cheap multiwii controller without any luck.. when i received my pixhawk controller i put it all together took my first flight without any problems no PID tuning was needed.

I upgradede to the newest stable firmware v 3.1.5, and after my hexacopter wobbles a lot around in loiter mode, and is very hard to control.

i had a some "toilet bowl" effect all so, but after i performed a compassmot that helped a lot.

i have been looking all around the internet, trying to find some answers. many says "its something about you PID's", yeah thats was also my thought, but i have tried tune my loiter PID's without any luck, its not getting better then i'm doing that.. maybe i'm doing it wrong :P, but its the same settings before i ran a firmware update :s

my copter flies without any problems in stabilize mode. its just in Loiter mode it have some strange behavior :s 

i attached my last log to this post and i hope there is some geniuses out here in this forum there can give me a good answer to my problem :) 

Best regards

Jon

2014-08-15 14-05-10.tlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Update:  after a lot of testing - i tried to install the beta firmware  " Arducopter v3.2-rc12" for a last try.. 

    and that solved all my problems, and i flies perfect! :)

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…