I have set up my pixhawk and plugged all my channels correctly. However, my pixhawk will only army whe I pull the right stick to the bottom left. However I checked my params and my throttle is set to channel 3 already. How can I fix this. Also, when flying the quad (3dr diy quad kit) my quad constantly flips over and cannot even take off. I have checked the motor rotation and props and they are all correct. Also, when I do the ESC calibration everything starts up together. However about 10 minutes later the motors are out of sync again. Please help! Thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi guys thanks for all the answers! I fixed the drone(bad pdb) and it flies now. However, it constantly drifts forwards drastically. When taking off it is fairly straight but after 5 seconds it begins to accelerate forward. In stabilize mode it drifts fairly slowly forward at a consistent speed. But in loiter mode it begins to accelerate forward and gets faster and becomes hard to control and will continue to get faster until it crashes. The take off is fairly straight up but it will begin to drift forward no matter the mode. The escs have already been re calibrated multiple times.
    • Hi Mike

      The drift in stabilize can be caused by two factors. You need to ensure your model is balanced correctly around the COG, move the battery to achieve this. Also the gyro calibration can cause drift. place your model on a level surface and view  the heads up display in the flight data menu in mission planner. the roll and pitch must be perfectly level. The loiter drift is more likely a compass or GPS issue. Is the compass head pointing in the correct direction in the flight data mode. Remember the compass heading will be offset by the true north amount in your area of the world.

      Good hunting

  • Check Mode 1 and Mode 2 of not only your radio, but what is selected in QGC or whatever you are using.

    Mode 2 is generally used in the US. It is easy to tell: the left gimbal on your RC unit doesn't spring back to the center when pushed up. This is throttle. In Mode 2 the arming procedure is bottom right to arm of the throttle gimbal.

    It sounds like this is where you have something wrong - between hardware and software config. 

    ESC calibration: there are so many ESCs with so many variables out there. What ESCs are you using?

  • "my pixhawk will only army whe I pull the right stick to the bottom left."

    that's because your RC control channel assignment is messed up, likewise, your motor connections are too, causing the flipping.

    read and follow documentation.

    • Here is a video
      https://youtu.be/IT8wHGiQrAw
      • Hi Mike

        Go back to the start of the setup procedure. Your machine is behaving very strangely. Have you gone thru all the required setup steps or have you simply put the hardware together. You need to upload quad firmware to pixhawk before any settings. Follow the the wizard in Mission planner in the Initial setup menu. Failure to do this will result in your quad not being flyable.

        Henny

    • Ok, however the drone does not always flip the same direction and it doesn't even lift off the ground before flipping, it just flips around 75% throttle.
      • Hi,

        What mode is your Tx?

        I'd suggest rechecking the radio calibration section, verify that the stick you are using for throttle moves the throttle.  Check that each of the other sticks move the bit you are expecting and in the right direction.  If not then fix that.

        Then I'd also use the motor test (with no props) and verify that each motor is correct.

        Chris

This reply was deleted.

Activity

Abdulatif Tlaib liked Ryan's profile
8 hours ago
DIY Robocars via Twitter
RT @SmallpixelCar: First time at @wsraceways. After tuning @HokuyoUsa lidar signal and camera sensor on @NVIDIAEmbedded, my car was able to…
Sunday
DIY Robocars via Twitter
RT @breadcentric: The handy bit about racing with self-driving cars is that one can type while the car is racing. Report from #AWSDeepRacer…
Jun 18
DIY Robocars via Twitter
RT @chr1sa: Our Bay Area @DIYRobocars meetup is now at 2,700 members. Next in-person events (in Oakland) are training day on July 17 and…
Jun 18
DIY Robocars via Twitter
Videos from the ICRA autonomous racing workshop are now available: https://linklab-uva.github.io/icra-autonomous-racing/
Jun 10
DIY Robocars via Twitter
RT @SmallpixelCar: Prepared race track for Warm Spring Raceways @wsraceways and looking forward to test my new car at RAMS RC @ramsaicar fa…
Jun 6
DIY Robocars via Twitter
RT @f1tenth: Trying out some nasty blocking maneuvers 🏎️🤖 #f1tenth #autonomousracing https://t.co/nMTstsaogM
Jun 5
DIY Robocars via Twitter
May 27
DIY Robocars via Twitter
RT @araffin2: I will talk this Saturday from 18:00 to 19:00 Paris time for the @diyrobocars community about learning to race in hours using…
May 27
DIY Robocars via Twitter
RT @a1k0n: Luckily the infeasible hairpin problem was easily reproducible in simulation and I could test the fix before bringing the car ba…
May 26
DIY Robocars via Twitter
RT @a1k0n: Another problem was that I was over-constraining the car's allowed accelerations, so it didn't think it could turn as tight as i…
May 26
DIY Robocars via Twitter
RT @a1k0n: Breaking the map up into two halves worked, but I had to be more careful about separating the inner track from outer. There's se…
May 26
DIY Robocars via Twitter
RT @a1k0n: Here's a datalog for my fastest lap of the day. Lap timer is tiny window lower-left. https://t.co/myrlWWrKUY
May 26
DIY Robocars via Twitter
May 26
DIY Robocars via Twitter
RT @a1k0n: Here was my car's POV. Man this track is confusing in first-person! After the incident my camera was all scuffed up and I was af…
May 23
DIY Robocars via Twitter
RT @circuitlaunch: Loved seeing so many familiar (masked) faces at Circuit Launch today for our first in person @diyrobocars in over a year…
May 22
More…