Pixhawk PPM Channel Order Incorrect - Updated Mapping - No Avail - Please help

Hello! I'm having an issue and am at my wits end, please help! 

I have a Pixhawk with Turnigy 9XR and OrangeRX R800X Radio which has "SBUS" output. I connected the SBUS out to the RC IN on the pixhawk and it worked great for maybe 10 flights. Then, when I powered on - the channel order was wrong. I have tried: 

- Upgrading firmware... seemed to work but once I unplugged the Pixhawk, when I powered it on next time the same problem was present.

- Trying to change channel ordering in the 9XR to from RTEA to AETR. No affect on anything.

- Changed channel mapping on the pixhawk as follows: 

This is how it is originally:

Pitch=2
Roll=1
Throttle=3

So, I changed it to: 

Throttle=1
Pitch=3
Roll=2

I selected "Write params" and it worked! But alas as soon as I either disconnect mission planner (even without unlplugging the pixhawk) and reconnect the same problems present themselves. The settings have not changed in the parameter list - but the problem is again there.

SO, if I go back to the original settings and write params, it works. Until disonnected or unplugged... again. 

If I can't get to the bottom of this soon I will blame my cat for looking at the pixhawk wrong. BTW: I have 3 pixhawks and have tried several firmwares, and the same issues is on all of them. The only thing I have not tried is a different radio which is only because I dont have one at the moment. But even if it is the radio, it seems hard to imagine that the radio is intellegent enough to want to piss me off so badly it will random change its settings to compensate for changes I make in pixhawk just to ruin my day. Pretty strange!

I have ordered some PPM encoders, but I just don't understand why it worked before and randomly stopped, or the fact there is no consistancy in the issue. Also worth mentioning the radio/rx works fine with typical pwm inputs on an APM. 

Any input is greatly appreciated! 

 

Views: 1179

Reply to This

Replies to This Discussion

Usually, you would change the channel order on radio, not Pixhawk

I tried, but was unable to do so. Perhaps I don't know how... I found a setting in the Templates section on the 9XR where I can change from RTEA to many other things, but none of them had any effect at all. I tried creating a new model in the memory with a different channel order, rebinding, etc. No luck!

In anycase, since the pixhawk has the channel mapping capability, should that method work? Or am I missing something? 

Thanks for the input!

not even sure what kind of firmware you run on pixhawk, but I am pretty sure you should rather focus in getting the radio to output channels in correct sequence.  - Should be easy to google , maybe this helps:  http://kiloohm.com/turnigy-9xr-apm-arducopterarduplane-radio-settings/

AntimatterCrusader 

I setup my Spekturm 8 channel transmitter to HobbyKing OrangeRx 10 SBUS receiver with my Pixhawk without difficulty. I input the BND output on the OrangeRX into the RC input of the PIX.

Hope this helps.

Vince

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service