Has anyone been able to configure a Pixhawk to work with a lightbridge HD link?

I'm able to get the Lightbridge control signals to the pixhawk but I've yet to figure out how to set the FailSafe.  When I turn off the RC controller, the lightbridge air module continues to output the same S.Bus channel signal levels. 

From talking to others I've found out that Lightbridge outputs the fail-safe "flag" in the header or footer (I'm not sure which) of the S.Bus signal (not the normal PPM channels like the pixhawk is expecting).  Can anyone confirm this is true and if so, how can I map the DJI Lightbridge failsafe signal to the Pixhawk's failsafe.

Thanks!

Views: 13152

Reply to This

Replies to This Discussion

solo link boards are available at $50 a pop

https://store.3dr.com/products/solo-link-im6-board

how to incorporate them into a pixhwark 2.1 build I've not idea though 

Hi ! do you use the telemetry fonction with the lightbridge ?

If yes, can you tell me how ?

Thanks.

CHRIS

Hi Andre

Any progress in useing LB2 with pixhawk?

are other rc channels accessible somewhere?

ANDRE Pierre said:

Hi,
i got a LB2 and i've question.


I would like to use it on a plane with a pixhawk inside.

Actually it's working fine with the SBUS output but could you explain me why i've only 5 channels and not 14 channels like i use it on a A2 controller ?

I've only A E T R and FLIGHT MODE (1,2,3,4,5 et 7).

Best regards

This looks interesting but may only be for mutirotor:

https://store.emlid.com/product/edge/

Hi, I read the SBUS signal, and the failsafe bit is:

I use lightbridge 2

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service