Pixracer + Copter V3.3.4-rc3 : DSMX, CPPM not working, S-BUS working

Hi Guys,

I have a Pixracer with APM Copter V3.3.4-rc3. I connected 2 different types of "spektrum like" satellites (DSMX : R110XL, DRX Orange RX) on the RC Input port of my pixracer using the RC IN, VDD 3.3V and GND pins.

But on Mission Planner, in the radio calibration windows, there is no detection of any signal from my satellite (My satellites are binded with my DX9 Spektrum receiver).

I also tried with a R720X receiver using the CPPM output but again nothing detected on the radio calibration windows.

It is only when I use a R920X receiver using the S-BUS output (with the same pinout) that the radio calibration displays the signal from my transmitter.

On the pinout (https://pixhawk.org/modules/pixracer), the RC IN pin from RC Input should accepts all this signals : PPM / S.BUS / Spektrum / SUMD / ST24 

So does it really work with DSMX and CPPM signal ?

I tried all my receivers (S-BUS, CPPM, DSMX) with my pixhawk and it works. 

Thanks for your help


Views: 2026

Reply to This

Replies to This Discussion

I talked too fast : S-BUS seems to work but when I try to do the radio calibration in Mission Planner, I get this error message.

Please, could anyone tell me if DSMX or CPPM works on Pixracer ?


Still with this issue ! I've just tried with a spektrum satellite (DSMX) but nothing detected by the pixracer.

Please, does it work for you ?



According to here, only dx7 and dx8 are currently supported for the spektrum satellite so that may be part of the dsmx problem. Though I'm having the same issue with a spektrum satellite/dx8/pixracer not being recognized on mission planner version 1.3.35

We may need to post here.


Thanks Scott for your answer. 

Following the link you gave to me, it is written : 

  • Currently satellites only work with the Spektrum DX7 and DX8 transmitters, Transmitters with more channels are (in progress).

And I'm using a DX9 transmitter. So it would make sense. However all my satellites with my DX9 work on my Pixhawk but not on the Pixracer. I guess this page has not been updated and think that this issue has been fixed.

Also on this page it is written that it is possible to use DX9,DX10 and DX18 with the Pixhawk.

Maybe the Pixracer firmware uses a old library for the receiver interface and does not allow DX9. I'm going to reduce the number of channel on my DX9 (if it is possible) and check if it solves the issue.

I'll post back the result.


I was under the impression that page only pertained to the PX4 stack, but it looks like you're right and the dx9 has been supported for a while: github issue.

It could still be the number of channels, but I also haven't found success with my dx8 yet either.

Have you had any luck Fabrice? I still haven't gotten it to work (two different satellites) and may look at other options.

I posted it in the general Pixracer thread (here), but it hasn't gotten a response so I'm not sure if there's many people using it(spektrum satellite, not the thread).


Hi Scott,

I tried with 2 different types of spektrum satellite and 3 different types of RxOrange satellites, with my Spektrum DX9 transmitter and my Spektrum DX6 transmitter and it did not work. I don't know what to do now.

To make it work, I'm using a 9 channel RxOrange that has a SBUS output and it works like that. I am not satisfyed because this RxOrange is very big and takes a lot of place on my Q250. I'll let you know if I get more information about this issue !


Same Here. I have been working on the Spektrum Satellite issue for 2 weeks. No go. I used a converter to go to PPM and SBUS that works with errors if the error messages are correct. Also waiting on a FRsky System. But so far the RixRacer is not delivering as promised.     I have not seen any air time as yet. Still flying my old Multiwii and Tarot ZYX-M.

I have a DX8. So far I've tried with no luck:

- Spektrum AR8000 satellite (3.3V)

- Spektrum AR8000 satellite (5.0V move the wire from pin 4 to pin 1)

- Orange R1020X (5.0V)

- Orange R1020X + R110XL

In all cases, the Rx light up so they are bound. But the calibrate radio screen in Mission remains grey.

Should we be submitting returns?

Did this ever get resolved for you?  I have a pixracer and a dx6 that I can't read from

Pixracer is not detecting my EZ-UHF ppm on copter with both stacks. Naza is working so I'm pretty sure the ez-uhf is right. sorry I couldn't help more.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service