Pixracer + Copter V3.3.4-rc3 : DSMX, CPPM not working, S-BUS working

Hi Guys,

I have a Pixracer with APM Copter V3.3.4-rc3. I connected 2 different types of "spektrum like" satellites (DSMX : R110XL, DRX Orange RX) on the RC Input port of my pixracer using the RC IN, VDD 3.3V and GND pins.

But on Mission Planner, in the radio calibration windows, there is no detection of any signal from my satellite (My satellites are binded with my DX9 Spektrum receiver).

I also tried with a R720X receiver using the CPPM output but again nothing detected on the radio calibration windows.

It is only when I use a R920X receiver using the S-BUS output (with the same pinout) that the radio calibration displays the signal from my transmitter.

On the pinout (https://pixhawk.org/modules/pixracer), the RC IN pin from RC Input should accepts all this signals : PPM / S.BUS / Spektrum / SUMD / ST24 

So does it really work with DSMX and CPPM signal ?

I tried all my receivers (S-BUS, CPPM, DSMX) with my pixhawk and it works. 

Thanks for your help


Views: 1902

Reply to This

Replies to This Discussion

A solution...solved... an answer... resolved...

I know I am coming into this a year later but I just got my Pixracers mounted on a drone and I am trying to use Spektrum DSMX satellite receivers and a Spektrum DX9 transmitter and I now have it working...

I read as many threads as I could and found one on the hardware thread talking about R200 on the board which was originally 470 ohms and that value was not working with Spektrum.


That thread talked about trying different values and I found reference to hardware revisions R12 and R14 and that revision R14 simply removed resistor R200 and this allowed Spektrum receivers to work BUT the bind procedure will not work. That is fine for my purposes as I am able to bind my satellite receiver hooked up to a Spektrum full receiver then just use the already bound satellite receiver with the Pixracer. 

I am uploading pictures I took showing the location of R200 on my V1.0 boards and showing it removed. it is a fly spec of a surface mounted resistor but I was able  to remove it with only a fine tip soldering iron with a blob of solder on the tip. Once the solder flows across the two ends of the tiny resistor it easily comes off and sticks to the tip. 

Hope this helps others that have had to resort to PPM encoders and other more complicated solutions. 

wow man , thanks a million....I just got a pixracer and was busting my head trying figure out why my spektrum DSM2 wasnt working right....and this did it, works perfect now!!!   sweeeeet

Thx.  Ivan R.  Makes it all worth while when you get a reply like this!

The other thing I will add was I was struggling using Mission Planner with Pixracer having issues with compass calibration, getting it to connect via wifi etc... and I switched to QGroundControl (QGC) and that was a night and day experience as well... everything just worked... connects smoothly, finds it on wifi automagically, firmware update smooth, sensor calibration smooth... I think my days with Mission Planner are done...

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service