This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

Views: 97869

Reply to This

Replies to This Discussion

Not sure if this is a different issue, or same that Randy has already seen,  ( He mentioned Master having this problem), but I have not been able to get any APM software to load on my Pixracer using QGroundcontrol or Mission Planner, including using the latest  MP and Beta MP.   I have tried both “Beta” and “Default ” loads in MP, but Pixracer will not see any radio on calibration screen (Genuine Futaba SBus Tx-Rx). Other calibration setup functions seem to work OK in MP after loading.  I tried disabling all Failsafe’s in MP, but MP won’t see radio input. Bars on radio cal Screen just go blank with no movement and will throw an error if you click complete.


Should I try setting the Min RC failsafe value to some minimum number-even though I already have the radio FS box disabled?  Currently it’s at 950 as that is what my other FC’s RC failsafe’s are set at, and I just copied the other APM profile to a new model on the Tx.


PX4 Stack seems to load/work OK using QGroundcontroll, but haven’t flow yet due to Flight Mode selection issues. (I never used Q till now and discovered late yesterday that Mode selection is keyed only to pulse width and must follow a specific order; so I think I need to reprogram my FG8 Ch5 Mixer to get Manual/Stabilize to kick in at proper pulse width so I can arm- I think).


Trying to load APM via Q seems to throw an error on some size parameters missing while downloading, but then seems to load FC, sensors calibrate Ok, but same issue – won’t see Sbus radio input with APM loaded.

Yes, MAVPilot works with the MAV-ESP8266 WiFi firmware that is used on the Pixracer. It uses UDP the same as APM Planner 2.0


I haven't personally tested it yet but someone else has reported that SBUS isn't working with APM/Pixracer.  Getting Pixracer sorted is definitely very very high on our to-do list.. just having some troubles juggling priorities to get these niggling issues sorted out.  I really hope we can do it this week.

I think we've gotten to the bottom of the "Bad Gyro Health" issue and I hope to release Copter-3.3.4-rc1-pixracer tomorrow with a fix.

The issue is there are errors on the SPI bus during the first 2 ~3 seconds after startup.  It could be the board's power is coming up slowly but I'm not a hardware person so that's just a guess.

The same things happens on the Solo so we're using the same fix which is to ignoring errors during the first two seconds after startup.  If the communication problems persist, the Gyro errors will pop-up meaning that this patch should not make the system less safe.

Great news :)

fantastic new randy. You guys rock! Beers on me :D 

Awesome work Randy, can't wait to get this in my micro quad.

thanks randy for all!

Tridge and I have released Copter-3.3.4-rc2-pixracer so it can be downloaded using Mission Planner's beta firmware link.  The fixes are in the ReleaseNotes but they're just small changes:

  • fix SBUS input
  • ignores accel and gyro errors during first 2 seconds of startup

We will give it a couple of days and if no significant problems are reported we will promote it to the official version.

Thanks for your patience in getting this sorted!

> fix SBUS input

The PPM Failsafe issue with Hott (Fs PWM), as described earlier, is fixed as well. Thx !

Recovery behavior is somehow different. The Pixracer has to be rebooted, to recognize the Rx again.

First video of Pixracer review and setup series from Painless360:

I've had very bad luck w/ that GPS... Two units, so I believe it is common.  It connected and pretends to work fine, but the copter drifts all over the place.    There's not a real "ublox" chip under that metal shield.. it's a clone of some sort.
HK and CSGshop are two others I've tried, and both of them work fine..

(That GPS stole about a month of fun from me over the summer, and I'd hate others to go through the same thing..  If you don't need super accurate position hold, or auto missions, then not so much of an issue..)

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service