This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

Views: 98164

Reply to This

Replies to This Discussion

Scott,I have heard similar for a number of people. I removed the shield and there is a uBlox chip under there. It is specifically

So your experience may vary, but I have used these extensively. I see very little difference between this GPS, the uBlox 8 from HobbyKing or the 35mm uBlox 8 GPS from CGS.

Randy, for Mission Planner users, it seems "Beta firmwares" does not make 3.3.4 available. 

Should it be available on the firmware site ( or somewhere else? I do see V3.4-dev is here, but not the pixracer branch. It looks like the Travis build may have failed too?

Thanks for your work on this!

Randy, do you have any information as to the UAVCAN issue with Zubax GNSS2?  According to Pavel it is a break in the UAVCAN code in APM.  My racer works with PX4 stack/Zubax but still no communication on the APM side.

Thanks, R

Johnatan: The link shows me "video suprised by user".

Regarding the video, that was a video for me to proof that was found... Sorry about that, the real video will be out early next week.

Sorry, I must have missed the chip when the cover popped off mine. I didn't notice anything w/ the Ublox logo on it.. But I was in a hurry to get it put back together and flying again at the time..
I did have trouble w/ the gps, though.  And nothing against that vendor.. I've got several of his products that all work great.

While I cannot confirm it is genuine... Here is the chip under the cover of my units.


My parameters are not saving. 

latest mission planner.  Not the beta, because the beta crashes before it even opens. 

Do I  need to use the beta MP?

Copter 3.3.4-rc2 is shown as being on the copter, up at the top of mission planner. 

I calibrate, save. refresh params.  They're all there.  Unplug the pixracer and plug it back in.  All settings gone back to the default/initial 3.3.4-rc2 settings. 

This is all while connected and powered via USB

Also, after rebooting and comparing params, a lot of the params rather than being reset to what they were bfore, are actually displaying as "NaN".

I just went through this entire procedure via telemetry modem and powered w/ a battery to see if it would help..
Set it up.  Powered off.  Powered on, and as soon as the flight controller initialized, two of the motors came on FULL and the copter was OUT OF CONTROL flying around my living room and almost killing (or at least hitting) my infant. 
RC controller was off.  Mission planner was disconnected. 

And as far as the settings...   About 1/2 of them saved.. it doesn't make sense to me. 
I think this will conclude my testing for today..  It's not working.

EVERYONE! Please remove your props until you have confidence in your configuration.

I would think a peek at your logs could be helpful at this point.

Yeah, lesson learned here.   I thought I had confidence in what I was doing.. And well, I do, in what I was doing.. But the copter is doing something I am not commanding..
Anyway..  won't happen again. 

Important info.. 
the master/alpha version of software DOES save my parameters.  SO whatever they fixed in master last week which did fix my ability to save parameters then, has not made it in to the beta, I guess. 

And I think all the issues I was having were due to communication issues.. Including the random motor starts.. I'm guessing something became corrupted while trying to communicate w/ the copter, and it went crazy..  MP was displaying "initializing APM" while it was spinning up the motors uncommanded.   And, that was repeatable.. every time I booted.  But, erasing and re-loading the software fixed it.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service