This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

Views: 97372

Reply to This

Replies to This Discussion

I have the latest ArduPilot build for Pixracer and I am unable to connect using Tower. I will try PX4, I am guessing it will work as QGroundControl has worked consistently.

Everything is working here :)  Nice to have predictable APM on it..  PX4 was a bit out of control for me...  But that could (likely) be  that I have experience tuning/configuring small APM copters, but am new to PX4. 
What do other people think about the flight differences between APM and PX4? 

Actually, I did have one issue.. I couldn't calibrate the ESC's.  Either through MP or manually (throttle up, reboot, etc). 
Manual, one at a time works.  Px4/qgc worked for the all at once calibration. 

I've had an awful time with ESC calibration on QGC/PX4. The 2-3 times I've succeeded it's the sort of thing where you look back and you're not entirely sure which thing worked. Yes, throttle up / reboot / reboot again / throttle down, etc. The ESC calibration in QGC never worked for me. I'd initiate it with only USB, plug in the battery when prompted, and it would "time out waiting for bat" every time.

Like you I'm much more accustomed to ArduPilot, but frustratingly the WiFi does not work at all for me in QGC or Mission Planner. I'm sure there's something I'm missing, but we should figure out what that is as other users will undoubtedly run into the same thing I did.

If PX4+QGC Esc Calibration is not working you should report in one of these places and you'll get a response:!forum/px4users

I must be doing something wrong. The ESP8266 does broadcast the PixRacer network and allows wifi connection giving out DHCP. I can ping it fine but I can't connect with MP or Tower and when I do a port scan I find nothing open. Are there parameters in arducopter that need setting to enable it?

My PixRacer with FW3.3.4 on my 3DR x4 is flying great with stab, pos hld, loiter, circle, missions and RTH modes on par with my Pixhawk.. I had to literally put it a box to get alt hd to get beyond the aerodynamic and light problems as we have seen in all the iterations. Have I heard of a software fix in the making?  I also discovered that stacking with the power module causes "compass variances" and high offsets.. All in all, I am very pleased with this addition.. Thanks to all the devs..

Did you set the connection to UDP in mission planner? 

I thought I had it working before, but with 3.3.3 it's not. I'll post back when I figure it out.

Yes, i specified port 14550 and it just waits for a UDP connection. It appears that MP expects the Pixracer to already be sending to that port. I can only assume that it knows the IP address since it gave it out via DHCP. What am I missing?

I don't think it's just you and I think their working on it.

There no connection with UDP. It just a bucket to put data in. No data, empty bucket. When you connect to the pixracer access point. It detect the connection. Sends the ip allocated to that device and starts sending the data to that IP address.

I think the issue is that the wifi module is not connected to data. I don't know what port it's on. I tried wiring a ESP7 to telem 2. But that also didn't work and I ran out if time to test. The same module works on a Pixhawk.

Hopefully I get some time later to understand what's up.

What version of ESP FW are you using?

Gus should be back in a couple days. If still not worked out, ping him on qgc github channel to help out.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service