This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

Views: 97241

Reply to This

Replies to This Discussion

are all these fixes etc going into apm-plane too or just copter? 

Lets just say the cat gets blamed for a lot of broken stuff while my wife is out shopping :-O

The Developers and Engineers have done an amazing job on this 36x36 mm square, I feel like I am flying an Indy car now.


Back from the flight... :-)

Well that was a big improovement for me, nearly everything seems to work now.

I just not get a GPS fix, no idea whats going wrong here. Does anyone else have the same issue?

I'll continue the tests on Friday.


all in both. In fact, it is likely it will be in a stable release of plane before copter, just because plane is on a faster release cycle at the moment than copter.

Some features aren't enabled on plane though - for example oneshot isn't on plane except for use as a quadplane (where oneshot can be used for the vertical lift motors). I could enable it on plane servos too, although I doubt it would actually make any difference.

Cheers, Tridge

Hi Artem,

I'm working on a patch that would allow the tricopter motors to be arranged on any channels. I'll let you know when its ready for testing.

Cheers, Tridge

Thank you very much! 

I will gladly test it, just let me know via a PM. 

Hi Edgar,

Francisco noticed that in my initial commit to add back frsky support I got the UART order wrong, which moved WiFi to SERIAL4 with the wrong baud rate. I've fixed it in a subsequent commit so WiFi is now on SERIAL5 with the right default baudrate. Can you check if the latest firmware from today fixes wifi for you again?

If it still doesn't work please post your parameter settings (especially SERIAL4* and SERIAL5*).

Cheers, Tridge

WiFi Via Laptop: seems good.  

WiFi with Phone: I did notice that with the phone I still get a "data link lost check connection", "Data link restored" back and forth about every 10 seconds or so even tho the phone is right on the table with the pixracer.  Something seems to be an issue with this.

On-board Mag Compass Calibration

id 0 works great

id:0 x:-87.92268 y:21.99235 z:-5.168818 fit:5.358186

id 1 always stops
id:1 46%

To fix my Compass issue I just uncheck compass 2 and run it again, but something seems to be an issue either with my internal compass or the firmware

awesome thanks! This might be 'plane' summer now :] 

Is there a way to change the SSID/password?

If not that could cause issues if we want to fly several pixracers at the track

Same issue here: only the external mag is working. They do not calibrate with the on-board method. Calibration in Mission Planner works but then I get a "Compass not calibrated" message.

Interference is about 8%.

As reported earlier the offsets of the internal mag are relatively high. But I doubt it is an issue with the mags because I had similar offsets on many Pixhawk based copters and never had any issues.

I'll post some logs later.


I've created a pull request for this:

With that patch applied you can set:


to move the yaw servo to channel 5. The magic number 39 is the RC function code for motor7. So this says "make RC5 output be the output for motor7". We could already move any of the motors on other multicopter frames in this way, we just hadn't extended it to the tricopter yaw servo.

It works for me in bench tests but I don't have my real tricopter setup yet so I can't flight test it. I've uploaded a prebuilt firmware for you to try here:

It is an experimental firmware so please do initial tests with props off and make sure it responds correctly.

Cheers, Tridge

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service