This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

Views: 92618

Reply to This

Replies to This Discussion

Thorsten, if I uncheck compass #2 and just use external I was able to complete it and get rid of the compass not calibrated message and fly.  But not with compass #2 activated.

Hi all, been away for some time, my pix racer has just turned up so will be following this thread. Very impressed with the board, will hopefully be trying this on a traditional helicopter and when the next one arrives on a HK Go Discover. 


will try tonight-tomorrow night, we are going to fpv this evening so I need my tri fully functional. currently it has pixhawk on it, will have to replace, a lot of stuff to fully test, I've being asking for this patch since February on the RCG without luck and honestly did not expect such quick result!


no problem.

I've now added a tricopter simulator to master which allowed me to test the change properly. It works fine, so I have pushed it to master. You will be able to get it with crtl-Q in missionplanner in a couple of hours


while we are at it, going back to AC 3.1.2 (ancient now) tricopter yaw control was much better with only the stock YAW PIDs (crisp and precise), now stock values make YAW really "delayed" and autotune returned yaw PIDs are plain hard to fly.

the performance changed back  in AC3.2 though it became worse in AC3.3 (both EKF enabled)

lol, I know you have a lot on your plate besides these, but it would be great if we could change servo control frequency (default set at 50Hz), I know a few tri pilots who run heli tail servos with faster PWM (333Hz). this would really be beneficial on mini-tricopters! 

Looks like I got the same issue with my Pixhawk-Clone, so it shouldn't be Pixracer related:


Thanks for the report - that adds valuable info that it's likely not pixracer specific.  It does look similar to the other crashes in that the DCM and EKF roll diverge.  Paul Riseborough has had a look at one of the other logs but couldn't determine the issue.  What he needs is logs with the IMU data at a high rate (400hz to be precise).  That can be done by finding the LOG_BITMASK param on the Standard Params page and checking "IMU_FAST" (and pressing the Write Parameters button).

By the way, we've moved the APM:Forums to a new discourse server here.  We haven't started official Copter 3.4 beta testing so I'm not actively monitoring it yet.. but that's where I plan to do most of the support for the next release.

I've pushed another update for brave testers to try. It will be in the autobuild in a couple of hours.

The new update makes the following changes:

  • fixes OneShot125 on BLHeli ESCs to not need power on board before ESCs
  • fixes so that only fast ESCs get oneshot and high rate. This prevents trying to run a tricopter tail servo at 400Hz
  • fixes use of safety switch to prevent any pulses before the safety is disabled

I would appreciate some test reports!

If you have previously tried MOT_PWM_TYPE=2 and it didn't work then please try it again with this change.

I just tested the build of today.

Unfortunately my ESCs (afro 4 in 1 20A) do not initialize with that build, I do not hear the final beep, instead they are beeping constantly every 2 second or so).

All three types (0,1 and 2) behave the same.

I uploaded the build of yesterday, and they work fine again (tested type 0 and type 1).

best regards



Do you have a safety switch connected? Did you press it so its not flashing? Previous builds didn't honour the safety switch.

If its still not working with the safety switch then please try setting BRD_SAFETYENBALE=0 and see if it then works for you.

Cheers, Tridge

Maybe I found another issue, my quad is quite stable with 3s Lipo, but If I replace it by the final 4s Lipo, it starts to oszilate.

I tried to lower the p-values  (ATC_ANG_PIT_P and ATC_ANG_RLL_P) but they seem to have no effect!

Am I using the correct P-value?

Does anybody have a hint for me?

Best Regards


I tried to lower the p-values  (ATC_ANG_PIT_P and ATC_ANG_RLL_P) but they seem to have no effect!

the ones you should lower are the rate gains, not the angle gains. The key gains that would cause oscillation are and ATC_RAT_RLL_{P,I,D} and ATC_RAT_PIT_{P,I,D}

Ideally you'd do an autotune and let it sort out good gains. Otherwise it would be worth having a read of the tuning docs.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service