This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

Views: 93842

Reply to This

Replies to This Discussion

Allen,

Also I'd like to check that you're using the OnBoard compass calibrator. I've highlighted below how to kick this off from the Mission Planner.

Yes, I've got PWM enabled now and with 3.4 still nothing. I've tried setting the MOTOR_PWM_TYPE to 0 and 2 and nothing on 3.4

I'm using RCTimer 30a ESCs loaded with the latest BLHeli firmware. Originally I had PWM disabled, then I enabled it but still nothing. With 3.4 I get no tones from the motors when I plug in the battery.

I had all the endpoints setup with the ESCs prior using Cleanflight on a SP F3 racer board. Everything was working fine. I swapped out the board with the Pixracer.

@DeLe, perhaps a silly question, but could it just be that you have the safety enabled? Either set BRD_SAFETYENABLE=0 to disable it or press the safety button to stop it flashing.

My apologies if you already checked this - it is a common issue with people coming from other flight controllers that don't have a safety switch.

Hi,

I am trying to troubleshoot issues with my ESC and PixRacer. Yesterday I solderd all the connections  to my Splash Drone. I believe it is XWing 40A ESCs.

And as soon as I connect power it beeps constantly every second. It is doing the same if I disconnect them from FC. The ESC calibration procedure will make them beep faster, but no reaction on the throttle. Tried diferent APM versions and no diference. ESC and motors are functional, I just swapped the controllers and PDB with ASCP4.

What are the steps to troubleshoot that?

I decided to give ArduCopter a next chance. Loaded latest MP beta and latest AC 3.4dev today, then V frame selected, then compasses calibration (all axes green values), then RC calibration - RC1-4 from 100 to 1900. Then started ACC calibration: level, left, right, down, up, back and... calibration failed .... fu.......ck... again? :(

Even more, I see "PreArm: RC not calibrated" but I did RC calibration a few times. I have FrSky X4RSB working in SBUS mode.

OK, when you first set up the rctimer's  with BLHeli did you use the pass thru on you the FC you were using.

If possible without alot of trouble can you plug each esc one at a time into your receiver and see if you can throttle up the motors without the FC being in the picture.

I have stated this problem before I am in the same boat as you . I have never been able to ACC calibrate in MP without a fail. Only ACC I can calibrate in MP is LEVEL. The only full ACC calibration I can do is using QGC, so this is what I have done to get the ACC calibrated. then I go back to MP. It has worked for me.

Randy

 

I too am having compass calibration issues

MP 1.3.37 build 1.1.5917.13431 APM:Copter V3.4-dev(39c29820)

I would like to be more helpful but coming from CF/BF, am not verse in issues that arise from this type of FC format

Could you please answer the below? 

3 things while configuring PixRacer compass in MP,

1) at top it says select device to quick configure par's. Do I select anything here?

2) Do you want what is boxed in pic above done in configuration as well as live calibration

3) Here, you want this information, How does one capture that for you. Could you spell it out for me?

I've never done that before. 

BTW...my COMPASS_CAL_FIT is 8 and has no values under the "range" column

1: Don't select anything
2: Just do the onboard calibration, which is the box in the above pic.
3: after you do step 2, it will show you the values he's asking for.. which is what he's pointing to in the pic above. 

4:  Enter a higher number.  If you do a compass calibration first, it will show you what you actually get (as per # 3 above), then you could enter that..   But then you'll probably have to calibrate again.
Otherwise, just enter a higher number.. 20 or 40, then calibrate. 

I don't know if this is the place to ask but I can't find much information and I'm curious about the status of Copter 3.4. I see there is work going into getting it to work on PixRacer but I can't find anywhere where 3.4 is in beta test like 3.3 and previous versions were in the past. 

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service