This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

Views: 97446

Reply to This

Replies to This Discussion

do you know when a stable release will be available for this great board

It's a great board if you bought the original. 
You've decided to save $30 and give the Chinese a bigger profit than AUAV is making, and AUAV is doing the work! 
I can't believe anyone would buy that clone board w/ it's horrible components and shitty soldering to save a few bucks. 
If they  priced the clone for what it looks like it's worth.. About $30, I couldn't blame you.. But at $70.00 it is really just ripping off AUAV and anyone who pays for it.

The pixracer clone is one of the worst examples of taking advantage of someone elses work, that I have ever seen..   They didn't even bother changing the silkscreen layer of the PCB, and it still says AUAV and has Philips name on it!  they literally just took the design files and ran w/ them... 
I'm hoping AUAV did the smart thing and put obvious errors in their published schematics, so the clones won't work w/out an engineer reviewing it and finding the issue.. But I doubt it.

Scott, sometimes not only some USS is the problem to buy a chinesse board, not all countries have the same import rules, I agree with you that 3DR first and here AUAV is doing the work so all my begining APM are 3DR and now I'm waiting an original Pixracer but, in the middle, my choice was Chinesse or nothing :( (never the clone trademark) and it's an open source so, everyone know what they want to choice; My chinesse boards works nice but I prefer to choice a board that is supporting developers because the board alone isn't usefull for me, but not easy to buy from my country, I spend a month or more trying to do it.

This weekend finally arrives to my hands :D :D :D :D

Scott, I agree with you. The clones are not supporting anything just making profit off of other people's hard work. Just parasites . How long before RTFQ jumps on this.

Hi Cala, I understand your frustration with trying to buy a genuine PixRacer - I've experienced the same.

With respect, when you buy products from companies that don't contribute to the development costs you reduce support for the ArduCopter Project. We are witnessing a critical transition in the Arducopter Project.
(reference - How to support Pixhawk and ArduCopter developers? Ensuring a future for APM at http://www.rcgroups.com/forums/showthread.php?t=2604735).

As a hobby-flyer, I've benefited enormously from this project as I'm sure we all have. I encourage anyone considering the purchase of a non-genuine PixRacer to think about the longer term consequences of your action and weigh that up against the few weeks or dollars saved.

I have built 3 pixhawk quads, and this is my first attempt at a (genuine :)) pixracer racing quad.

The instructions for calibration are very clear. When turning back on in calibration mode, I only get one long tune at the start and then nothing else.

I have done this 5 times. After rebooting, two of the times I had throttle control on all four motors. The other times, the throttle did nothing. When the throttle worked, the motors did not spin up to 50% mark of the stick, the other time they span up straight away. When they span up straight away, I thought maybe the calibration had worked even though I had not heard any tones. I put on the probs and promptly flipped it on the ground and broke some cheap props.

I am running AC3.3.3. I have the safety switch connected, but I am aware it does not do anything. It is an EMAX nighthawk with the ASCP4 PDB.

There is only so many times I can try the same thing. Any tips on how to trouble shoot this?

I would just like to report a solution to a problem that I had.

I had real difficulty arming the pixracer. AHRS, Compass and GPS checks would not pass on startup.

Using an external GPS/compass I thought would fix it. However it did not fix the compass mis-match error. The trick was I had to do the compass calibration with the whole system powered. The compass numbers where completely different with the system powered and unpowered, probably given the VTx was nearby.

To get past the GPS pre-arm check I tried to take off in Stabilize mode, which had worked for me on other quads in the past. However it did not work. Some research showed that even though the pixracer is in Stabilise mode, it will not take off without GPS lock IF the geofence is enabled.

Once these two things where fixed, the AHRS problem was also gone.

I have a 1 in 10 success rate connecting the PixRacer to Mission Planner via USB.

The two times it has connected the "Downloading parameters" window hangs, but if I close it, after waiting for a bit, then I can download them again with no problem.

The same computer connects to two other quads with pixracers no problem first time.

Specs: AC3.3.3. USB. Windows 10 PC.

At one stage I thought I had found the problem with a bent micro USB connector. But replacing the cable did not help.

The only thing I can think of trying is loading the plane firmware on the pixracer then AC3.3.3 again. Thoughts?

Calibration and a few other things do not work with 3.3.3.  This firmware does not fully support the Pixracer.

I have been connecting and connecting to upload custom firmware to Pixracer for some time now and never have a problem.  I did have a problem one time when switching from the PX4 flight stack to the APM flight stack.  I used QGround Control to kick it and from then on no issues.  More than likely its a USB hardware/driver issue as the Pixracer shows up on a different port with a different name.

I noticed that the Pixracer shows up as a different port and name to the pixhawk when connected via USB, which suggests a different driver and hardware set to the pixracer.

I doubt it is USB driver related on the computer side when Pixhawks connect just fine.

Did you mean USB driver hardware/driver issue on the Pixracer side?

What computer are you connecting with?

@Thorsten, how did you fix your driver issues on Windows? I have not been able to connect reliably to the PixRacer. I can connect reliably to a PixHawk.

AC3.3.3. Windows 10. Latest Mission Planner.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service