This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

Views: 97858

Reply to This

Replies to This Discussion


I tried to use Out 5 for Camera Pitch.


With the origin Pixhawk we had to set RC9_FUNCTION to 1(PassThru) for AUX 1.

So as you explained this should be RC13 for Pixracer OUT 5.

But neither RC9 nor RC13 have an effect on the Out 5 in the Graphs of MP.

Must I set some other Params?

MP 1.3.38 /  APM Copter 3.4-rc1 / Pixracer R14

Thanks for your help.

I tried to use Out 5 for Camera Pitch.

On the pixracer that would be RC5_FUNCTION. The Pixracer outputs are RC1 to RC6.

Hi, please check compass_dev_ID3 263178  default orientation settings.

X offset -659, while compass#1 and #2 have acceptable offsets suggests wrong orientation my external compass sits right above the pixracer.

Also, since compass_dev_id 66826 and  263178 are internal and unique to the chips used, I suggest to tie orientation settings to the specific I2C addresses instead of the way it is done right now. 


Hi Andrew,

Thank you for the quick answer.

It works. Even with BRD_PWM_COUNT = 2 or 6.

But Channel 5 ist used for Copter Modes, and Channel 6 for Tuning Params.

Therefore the remaining Outputs of Pixracer with Quadcopter are not realy useful as Aux Out.

Nearly every RC has 16 Channels and we are clamped to 8 with APM. :-)

Had the same issue, after loading one of the dev versions compass_use3 was set to 1, took me good 10min before i realised this, though I am very sure I did NOT set that param. After setting it to 0, all was fine. Btw, I think compass3 orientation is not set correctly in the code,  its X offset is around -600. Or Is it just too close to an LDO? 

Thorsten, It's usually just a few or maybe 10 degrees. 

I really don't think it's the vibes and dirt, etc..  If it is, that's a problem, too!!  It worked fine w/ 3.3.. and on a racer, chipped props, mud, etc, will happen!  And in the end, my vibes are not bad!  They are in the green the entire time..  They are as low as the example copter on the instructions about monitoring vibe levels.  And, I have cleaned my props, gotten my vibes down below 5, and the issue remains.

Plus, if you look at the logs, as soon as I switch to Alt_Hold, there are a bunch of yaw commands showing up.  They're short spikes to 100%.. when I switch out of Alt_Hold, they go away, or get much less. 

The issue is obvious from my logs.. maybe not the cause... But you can clearly see what is happening.. (look at the ATT yaw and des yaw graphs)

Also, Thorsten mentioned loiter.. For some reason, the issue is NOT in loiter!  I have a log showing the yaw spikes in alt_hold, and then I switch to loiter, and they immediately stop.. I switch back to alt_hold and they are there again!    I thought loiter would have all the same issues as alt_hold, because alt_hold is part of loiter.. But the issue is not present in loiter.

Yes I noticed the same thing. very strange... I thought I needed to tweak the PIDS on the yaw or something. It just seemed to have less control over itself with yaw. I turned off EKF2... seemed better but I sort of lost track what all I did. It's in this thread somewhere. Definitely did not have the issue in 3.3

I'm still having a couple old problems, with the current beta...  I thought they were fixed, but maybe not..
I can't calibrate ESC's in oneshot mode.  They never enter calibration mode... they just activate as normal when rebooting into calibration mode.   The flight controller does go into calibration mode, but the ESC's don't seem to care. 
And, the 3rd compass does not work.  As soon as I disable it, I can arm.  If it is enabled, I get "compass not calibrated" even though it is. 

Worth mentioning...
I just 'landed' in a lake, completely submerged.  Took it out, dried it off, and she still flys. Even all my FPV/Camera equipment is OK.
It's actually more impressive than that, because I tried powering it on when it was about 1/2 dry.. and it worked for a few min and died.  I was sure it was lost.  But after a complete dry, it's ok!!

In my previous post I also had this compass not calibrated warning, even though I thought it was.

My steps were: select all compass checkboxes. Power on the system with the battery as well as the USB (or the calibration numbers will not reflect the power going through the system). Calibrate the compasses. Even though the message says "automatically saved" I still write params to the board.

Then I go in and deselect the checkboxes for internal compasses. Then I write params again.

Worked for me to get rid of "compass not calibrated" error even though I thought I had.

I applaud your efforts for going through all of that to figure it out. But my question is WHY did you have to in the first place? I understand this is Beta, but, this is not like CF/RF where people are using different FC's to bring another variable into the mix. Everyone who has interest in this thread has a PixRacer and has/have used MP/Copter. Shouldn't the process to get everything calibrated properly be the same for everyone and well documented? After all, these calibrations ARE needed to fly. Being new to this, I would never have thought of doing all that and would have chalked it up user error and bugged everyone (like I did) or bad hardware. I almost sent my PixRacer back because I could not get my compasses to calibrate and couldn't get passed that compass not calibrated error. And everything I read lead me to believe I had bad hardware. I personally have had no luck with MP/Copter what so ever. I gave up and went to QGC/PX4 hoping at a later date. I hope it gets sorted out because I really like the MP layout and what Copter had to offer. QGC/PX4 documentation/support wise just isn't there like MP/Copter is.

Sorry if this seems like a rant, don't take it as one, just frustration.       

Personally, if I didn't have a background in IT and EE, I'd have thrown the thing on the ground and stomped on it and cussed a lot.... 
But, I'm used to finding bugs and solving problems for people.. (it's what I do for a living). 

From a beginners perspective, it would be impossible to know what is a bug and what is a configuration error or hardware error, etc..
What I don't understand is why me and a couple others are saying we have these issues, and can reproduce them w/ multiple configs and different flight controllers.. then a few other people are posting saying 3.4 is all good and no problems whatsoever...  I don't understand what the difference is there..
But from the beginning, PX4 was the only software they said worked 100%..  Everyone using APM knows they're testers.

Compass #3 got marked as  'use_compass'?

Had the same problem a few posts back... 

If you've spent enough time with AC you know that sometime during firmware update settings get changed though you never changed them yourself. 

The best course of actions is to have a backup file of your settings, than if AC acts weired after a firmware upgrade just reset all params to default in full parameter list, write, reboot and load your saved file back on... now, you need to have this file "prior" to the situation otherwise you'll be uploading the same boguous params. Its not pixracer fault amd i am not sure it is even AC fault, maybe some eeprom gets affected by the firmware upgrade process... its definitely not "every time" but does happen occasionally. 

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service