This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

Views: 96880

Reply to This

Replies to This Discussion

is there a reboot button on the cloneRacer? if so, try warm reset, maybe the ldo they've used does not stabilize quick enough, so baro fails to start and since there are no more retries the process aborts.

I can add to the discussion here about the clone PixRacer as I have one.I also have a genuine one on order from AUAV. The link that Phillip posted where Mr. Meier is identifying 2 LDO voltage regulators (U304 &504) as being the problem is what the Chinese cloner is now saying also. In fact you can see a note to this affect on the GLB website Pixracer kit page. The schematic calls for a LP5907-Q1 with a "RAHQ" chip identifier. The clone board regulators are identified as "LLVB". These have very similar specs assuming the cloner used a genuine TI device. In any case it's not the same device called out on the board BOM as Mr. Meier noted.

Hey. Yes i have a reset button. Will try soon. Will the nsh reset have the same effect? Maybe some delay in the startup script?
Or adding another regulator to before the batt?

i was wrong. i dont have reset. Or i dont find it. Neither on the official schematics.. 

well, back to topic: i got my PixRacer Board from Nick. I come from PX4 and now loaded AC 3.4 rc1 and so far all fine. One thing, I cannot seem to connect the wifi esp to mission planner. It does work with QGC and there, I can modify all parameters. My esp still creates network "pixracer"

In mission planner I cannot change the esp settings (which are "arducopter"

How do I go about it?

if you are handy enough with the heat gun, try replacing LDOs with the genuine parts from Mouser/Digikey. 

Dave said:

I can add to the discussion here about the clone PixRacer as I have one.I also have a genuine one on order from AUAV. The link that Phillip posted where Mr. Meier is identifying 2 LDO voltage regulators (U304 &504) as being the problem is what the Chinese cloner is now saying also. In fact you can see a note to this affect on the GLB website Pixracer kit page. The schematic calls for a LP5907-Q1 with a "RAHQ" chip identifier. The clone board regulators are identified as "LLVB". These have very similar specs assuming the cloner used a genuine TI device. In any case it's not the same device called out on the board BOM as Mr. Meier noted.



Artem said:

if you are handy enough with the heat gun, try replacing LDOs with the genuine parts from Mouser/Digikey. 

Wow, that would be awesome... if I could do that : ) Is there anyone having the same problem and resolved by replacing LDO?

As a clone user, based on your information, i decided to give a try and buy an original. But... PixRacer is out of stock :( 

Do you know how long does it usually take to be in stock again?

If this will take long:

Do you maybe have a spare pixracer to sell? Im only looking for original, used is good as well. (only if it does not hurt the economy, Auav, etc.. you know.)

Anyways, i will still try to fix my clone with 3.4, regardless of having a genuine one or not. Hope you wont hate me for that.

Then I can use my drone and hack a faulty one at the same time :)

I think your a little confused here.  3.4 has nothing to do with PixRacer.  3.4 is all about new motor mixing and terrain following.  The fact that Pixracer works with this release is a side note that one of the developer decided to do.  If you want support for the Pixracer you should be using the PX4 flight stack as they made changes just for that hardware.

As far as making clones work with the firmware, I believe that they try to make all hardware regardless of who made it work.

This is where DJI and Apple excel as they do not release any hardware that is not fully supported by the firmware.



Michael Burmeister said:

I think your a little confused here.  3.4 has nothing to do with PixRacer.  3.4 is all about new motor mixing and terrain following.  The fact that Pixracer works with this release is a side note that one of the developer decided to do.  If you want support for the Pixracer you should be using the PX4 flight stack as they made changes just for that hardware.

As far as making clones work with the firmware, I believe that they try to make all hardware regardless of who made it work.

This is where DJI and Apple excel as they do not release any hardware that is not fully supported by the firmware.

Well, I wasnt confused until your post :)

So this is the reason for having a 3.3-pixracer branch with not-merged, pixracer specific changes on github. And my understanding pixracer supports both PX4 and Ardupilot as well, was wrong. On PX4, i have other issues, but lets not get into that on this forum.

What is the recommended FC for:

- 250 size quadcopter. (not racing, just learning to fly, test autopilot, hacking, having fun with DIY sensors like sonar, run self-written-scripts, servo camera tilt stabilization)

- 450 size quadcopter for hobby aerial photography, supporting about the same than 250.

Its ok if i have to solder, read documentation, measure voltages, create special cables, do configuration etc.

The only requirement is that it needs to 'work', and have a longer-than-APM lifespan (expecting updates for at least a year).

Thanks a lot for clarification.

We actually have plenty in-stock, I have forced an update to the site to remove that erroneous data.. We already ship from inside the EU and the USA.


Marcell Kovacs said:

As a clone user, based on your information, i decided to give a try and buy an original. But... PixRacer is out of stock :( 

Do you know how long does it usually take to be in stock again?

If this will take long:

Do you maybe have a spare pixracer to sell? Im only looking for original, used is good as well. (only if it does not hurt the economy, Auav, etc.. you know.)

Anyways, i will still try to fix my clone with 3.4, regardless of having a genuine one or not. Hope you wont hate me for that.

Then I can use my drone and hack a faulty one at the same time :)

Hi Philip,

This is great news. See it in stock.

Will ArduCopter 3.4 and later versions support pixracer?

post by Michael: "3.4 has nothing to do with PixRacer." scares me a bit. how is it then?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service