as of 1.0.96, the planner now used .net framework v4, make sure you have it installed.



Views: 1033

Reply to This

Replies to This Discussion

Is that going to play nice with Mono? I thought .Net 4.0 support was a bit iffy still....

Unfortunatly no ironoython took care of that

Iron Python? Well, FWIW Iron Python can run on CLR2 and is supported by Mono, only problem is interop form C# => DLR is a bit harder due to the lack of 'dynamic'.


However looks like .Net 4.0 should work according to this page.



ive tested on mono 2.8 on windows, and no luck there.

Hey Michael. Iv updated to .net 4. But it still says APM planner has stopped working. It works perfectly on my desktop (x64 win7) but wont work on my laptop (x86 win7)


any suggestions?


Thanks :)


ive tested on windows xp 32 bit, and cant find any issues.

After a bit of wrestling with 7. All is working 100%!

Thanks Michael!



Mine also stopped working since 1.0.97. I do have .net 4.0, Windows XP Pro SP3, I used the update feature from the Help page to update from 1.0.96 (which worked fine, besides the "Hello World" messages I would get in the console screen ;)


It seems the problem comes from IronPython, which I'm not familiar with. The exception dump goes like this:


Unhandled Exception: System.Reflection.TargetInvocationException: Failed to load language 'IronPython 2.6.1': Could not load file or assembly 'Microsoft.Scripting.ExtensionAttribute, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. ---> System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Scripting.ExtensionAttribute, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.File name: 'Microsoft.Scripting.ExtensionAttribute, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35'   at System.ModuleHandle.ResolveType(Int32 typeToken, RuntimeTypeHandle* typeInstArgs, Int32 typeInstCount, RuntimeTypeHandle* methodInstArgs, Int32 methodInstCount)   at System.ModuleHandle.ResolveTypeHandle(Int32 typeToken, RuntimeTypeHandle[] typeInstantiationContext, RuntimeTypeHandle[] methodInstantiationContext)   at System.Reflection.Module.ResolveType(Int32 metadataToken, Type[] genericTypeArguments, Type[] genericMethodArguments)   at System.Reflection.CustomAttribute.FilterCustomAttributeRecord(CustomAttributeRecord caRecord, MetadataImport scope, Assembly& lastAptcaOkAssembly, Module decoratedModule, MetadataToken decoratedToken, RuntimeType attributeFilterType, Boolean mustBeInheritable, Object[] attributes, IList derivedAttributes, RuntimeType& attributeType, RuntimeMethodHandle& ctor, Boolean& ctorHasParameters, Boolean& isVarArg)   at System.Reflection.CustomAttribute.GetCustomAttributes(Module decoratedModule, Int32 decoratedMetadataToken, Int32 pcaCount, RuntimeType attributeFilterType, Boolean mustBeInheritable, IList derivedAttributes)   at System.Reflection.CustomAttribute.GetCustomAttributes(Assembly assembly, RuntimeType caType)   at System.Reflection.Assembly.GetCustomAttributes(Type attributeType, Boolean inherit)   at IronPython.Runtime.PythonContext.LoadBuiltins(Dictionary`2 builtinTable, Assembly assem)   at IronPython.Runtime.PythonContext.CreateBuiltinTable()   at IronPython.Runtime.PythonContext..ctor(ScriptDomainManager manager, IDictionary`2 options)
WRN: Assembly binding logging is turned OFF.To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.Note: There is some performance penalty associated with assembly bind failure logging.To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
   --- End of inner exception stack trace ---   at Microsoft.Scripting.Runtime.LanguageConfiguration.LoadLanguageContext(ScriptDomainManager domainManager, Boolean& alreadyLoaded)   at Microsoft.Scripting.Runtime.DlrConfiguration.LoadLanguageContext(ScriptDomainManager manager, LanguageConfiguration config)   at Microsoft.Scripting.Runtime.DlrConfiguration.TryLoadLanguage(ScriptDomainManager manager, AssemblyQualifiedTypeName providerName, LanguageContext& language)   at Microsoft.Scripting.Runtime.ScriptDomainManager.GetLanguageByTypeName(String providerAssemblyQualifiedTypeName)   at Microsoft.Scripting.Hosting.ScriptRuntime.GetEngineByTypeName(String assemblyQualifiedTypeName)   at IronPython.Hosting.Python.GetEngine(ScriptRuntime runtime)   at IronPython.Hosting.Python.CreateEngine()   at ArdupilotMega.MainV2..ctor()   at ArdupilotMega.Program.Main()



I also installed .net 4.0 on my windows xp.  Still can't get mission planner to run.  It always keeps saying it needs .net 4.0 to run.  So I repair the install, install it again, all no avail, it keeps moaning that it needs .net 4.0

Stupid m$ crap :(

I have got it running on XP with .Net 4 but I can't connect to my APM now. It just throws the following error...


Upgraded both my APM's to Ardupolane 2.26 and they both throw the exact same error below..

This is how I fixed mine! Delete the current mp. The one you upgraded. Download it fresh from


Unzip and run. Worked for me :)

That worked for me too ! Thx !


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service