Hello, 
I have an APM 2.5 installed in a flying wing airframe. I previously had this APM in a multicopter and had it working well. I installed the ArduPlane V2.72 on the APM, and downloaded and installed the Skywalker Parameters, and calibrated my radio. 

However, while this may be a noob like question, I for the life of me cannot get the elevon mixing to work right. It seems no matter what combination of reverse channel selections I make (APM & Radio), how I hook up the servos, it's either wrong in stabilize or manual mode. 


Is there a setup guide around for this? I saw https://code.google.com/p/ardupilot-mega/wiki/APM2RC but I am not certain which is correct for the wing - the # selections and color coding is opposite. I guess I should start off with knowing for a fact which wing servo gets hooked to what input

Also, do you guys typically need to reserve any channels on the radio itself? Also, does the mixing need to happen on the radio or APM? Or both? 

Thanks!

Views: 721

Reply to This

Replies to This Discussion

P.S. I am using a HobbyKing Phantom flying wing. The servos are on the bottom of the wing, with the control side facing outward

You need to do this in the correct order. Calibrate the radio, then in stab adjust the direction of the servo until the surfaces response correctly when you pitch or roll the aircraft, then select manual and adjust the radio to get the correct directions as you move the sticks
Connect as per the wiki and mixing needs to be set on the APM and the rc

Thank you for your help! However, is this is mistake in the Wiki? 

I just checked my wings., all have output 2 from APM to the starboard / right wing. All fly ok. The picture is correct, the text is wrong .

I tend to agree that the text is wrong it should be 1 to port and 2 to starboard.

I recently pulled everything apart and when I plugged it all back in, everything was OK in manual but stabilize was wrong.

I thought something else must have changed but the only change necessary was to swap outputs.

I would tend to disagree with first setting up stabilize however.

I made sure everything worked in manual by mixing the radio.

Then used the reverse options in mission planner to get stabilize working.

Just my thoughts though.

I had one wing that had the servos in unusual setup and set it in man first, then stab, there was always one combination that would not operate correctly. Doing stab first always worked and is less trouble. Try both!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service